[IronPython] Anyone have IronPython running on Silverlight RC0 yet?

Dan Eloff dan.eloff at gmail.com
Tue Sep 30 04:20:28 CEST 2008

It was easy to build the latest sources with silverlight rc0, but
there seems to be some issues using the resulting binaries.

InitializeError- Failed to load the application. It was built with an
obsolete version of Silverlight

I went back and uninstalled silverlight and silverlight sdk + tools,
and physically deleted C:/Program Files/Microsoft SDKs/Silverlight. I
reinstalled, rebuilt everything, but no luck. The only thing I could
have from an older silverlight is I kept the old chiron.exe.config
file, but I don't buy that it's the problem.

The error here is not very helpful since it's impossible for the
binaries to have been built with anything but the very latest
silverlight version.

I'm not sure what's going on here. Is IronPython supposed to be able
to work with RC0 in it's current state? Jimmy, if you're reading this,
have you had any success with the DLR on RC0?


More information about the Ironpython-users mailing list