[IronPython] Trouble with IP 7.0 and VS 2010

Dino Viehland dinov at microsoft.com
Tue Aug 10 22:45:38 CEST 2010


Kurt wrote:
> Hi Dino
> 
> Maybe I should just try compiling the source locally.  Do you know where
> I can find instructions to do this?
> 

If you're willing to build from source that's great.     Do you have VS 2010
Pro or above?  You'll need it to build from VS but I think you can just do
Msbuild from the command line w/o it (haven't tried that though).  Either way
You'll need to install the VS SDK (http://www.microsoft.com/downloads/details.aspx?FamilyID=47305cf4-2bea-43c0-91cd-1b853602dcc5&displaylang=en)

>From there it should be as simple as downloading the source from the 
Source Code tab on Codeplex and then opening IronPython_Main\Solutions\IronPythonTools.sln.

You might also need to copy IronPython binaries into IronPython_Main\Tools\IronStudio\Bin
(we have those checked into our tree but for some reason they don't 
propagate out).

If you have VS Pro to run this you'll want to right click on the IronPythonTools
project select properties, and change the Debug tab to Start external program,
run devenv.exe (C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe),
and then change the command line arguments to be "/rootsuffix Exp /log".

At that point F5 will simply work and launch VS under VS and life should 
be good.

If you run into any problems let me know - you may be the 1st person trying
to build externally.





More information about the Ironpython-users mailing list