[IronPython] Minor Weirdness with 2.6.1 RC1

David DiCato ddicato at microsoft.com
Fri Feb 12 23:56:42 CET 2010

In IronPython, clr is a builtin module, so this error should theoretically be impossible. How did you run the script when it gave you the "Can not import module clr" error?

-----Original Message-----
From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of Joshua Kramer
Sent: Friday, February 12, 2010 10:09 AM
To: users at lists.ironpython.com
Subject: [IronPython] Minor Weirdness with 2.6.1 RC1


I noticed some minor weirdness with RC1.  I un-installed 2.6 and installed 
2.6.1 RC1, then went to run a database backup script I have.  The first 
line in the script is...

import clr

When I ran the script, it said, "Can not import module clr".  Tried this a 
few times with the same result.  Then, I ran ipy from the command line, 
and tried 'import clr' at the prompt.  Everything was working fine after 
that, even across reboots.

Users mailing list
Users at lists.ironpython.com

More information about the Ironpython-users mailing list