[IronPython] difference in compiling ipy in 3.5 vs. .NET 4.0?

Ken MacDonald drken567 at gmail.com
Tue Oct 5 17:59:58 CEST 2010

I am getting much farther with my app now that I can actually run it as an
.exe; and running under VS is a HUGE help. Currently, the app is dying on
the following statement:

import os

When I run it in VS or from the ipy command prompt, "import os" seems to
work fine, "dir(os)" yields a bunch of symbols, for instance.

When I run it as a compiled .exe, it runs up to that point, and dies with an
exception "no module named os".

This seems like it must be some sort of path issue or similar. Where is the
assembly for "os",
and how do I ensure it gets found from my .exe - is there a specific env.
variable, or the Windows %PATH% e.v., or something I haven't AddReference'd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20101005/5636240e/attachment.html>

More information about the Ironpython-users mailing list