[IronPython] IPy 2.7 successfully built for .NET 3.5, but problem w. indirect v4 dependencies

Jaromír Matýšek kerray.cz at gmail.com
Mon Mar 28 17:09:23 CEST 2011

I've suceeded building 2.7 for .NET 3.5 (I'm using it in SharePoint, so 
there's no way to use .NET 4) and it works, using v2release configuration. 
I've built IronPython, IronPython.Modules, Microsoft.Dynamic, 
Microsoft.Scripting and Microsoft.Scripting.Core dlls.

However, when I reference my class library (which is referencing my 
custom-built 2.7 dlls) from another solution and try to compile, I get 
several instances of the following warning and of course errors wherever I'm 
using some of my class library functions:

The primary reference "SPTools ... " could not be resolved because it has an 
indirect dependency on the .NET Framework assembly "mscorlib, 
Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" which has 
a higher version "" than the version "" in the current target 

I've now spent a day and half trying to get rid of this problem. I've combed 
through the project files - they're all switched to v2, there's nothing even 
vaguely v4 related, it all compiles too, the problem remains.

I'd be very grateful for any ideas. 

Jaromír Matýšek

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20110328/2008c24a/attachment.html>

More information about the Ironpython-users mailing list