[IronPython] IPy 2.7 successfully built for .NET 3.5, but problem w. indirect v4 dependencies

Markus Schaber m.schaber at 3s-software.com
Wed Mar 30 13:32:05 CEST 2011

Hi, Jaromir,


We had very strange problems with 2.6.2 when we had both the .NET 2 and .NET 4 versions installed in the GAC. (The same DLL, the same key, the same version…)


To prevent those problems from happening with our customers, we ship custom-built IronPython dlls, renamed and signed with our own key.


Best regards

Markus Schaber


We software Automation.

3S-Smart Software Solutions GmbH
Markus Schaber | Developer
Memminger Str. 151 | 87439 Kempten | Germany | Tel. +49-831-54031-0 | Fax +49-831-54031-50

Email: m.schaber at 3s-software.com <mailto:m.schaber at 3s-software.com>  | Web: http://www.3s-software.com <http://www.3s-software.com> 
CoDeSys internet forum: http://forum.3s-software.com <http://forum-en.3s-software.com> 
Download CoDeSys sample projects: http://www.3s-software.com/index.shtml?sample_projects <http://www.3s-software.com/index.shtml?sample_projects> 

Managing Directors: Dipl.Inf. Dieter Hess, Dipl.Inf. Manfred Werner | Trade register: Kempten HRB 6186 | Tax ID No.: DE 167014915 


Von: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] Im Auftrag von Jaromír Matýšek
Gesendet: Mittwoch, 30. März 2011 12:45
An: ironpy at googlegroups.com
Cc: Discussion of IronPython
Betreff: Re: [IronPython] IPy 2.7 successfully built for .NET 3.5, but problem w. indirect v4 dependencies


I wish it was so easy. My dlls build against 3.5, there's no reference to v4 dlls in the project, and when I open the final dll with Reflector and go through the references (and their references, and theirs...) there's still no v4 reference. If it was compiled against .NET 4.0, it wouldn't even run in SharePoint - and it does.

And the culprit is really somewhere among 2.7's Microsoft.Dynamic, Microsoft.Scripting, Microsoft.Scripting.Core and IronPython - when I go back to  2.6.1 versions, my dll can be referenced OK. 

Again, according to Reflector, there is no v4 reference anywhere in the dlls I compiled, nor in their references. There are some instances of people solving similar problem, but none of the suggestions worked for me.

Maybe I did something wrong when building 2.7 for v2. Could maybe someone post binaries of 2.7 for v2 please?

Well, I'll just continue using 2.6.1 for the time being.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20110330/50b16aee/attachment.html>

More information about the Ironpython-users mailing list