[Ironpython-users] Fwd: SymPy and IronPython 2.7.4

Pawel Jasinski pawel.jasinski at gmail.com
Wed Apr 9 11:25:16 CEST 2014


---------- Forwarded message ----------
From: Pawel Jasinski <pawel.jasinski at gmail.com>
Date: Wed, Apr 9, 2014 at 11:24 AM
Subject: Fwd: [Ironpython-users] SymPy and IronPython 2.7.4
To: "ironpython-users at python.org" <ironpython-users at python.org>


---------- Forwarded message ----------
From: Pawel Jasinski <pawel.jasinski at gmail.com>
Date: Wed, Apr 9, 2014 at 11:02 AM
Subject: Re: [Ironpython-users] SymPy and IronPython 2.7.4
To: Andrew Ayre <andy at britishideas.com>


Here is the workaround which let me install the package:

*** sympy/__init__.py.orig      2014-04-09 10:59:53.361779800 +0200
--- sympy/__init__.py   2014-04-09 11:00:02.906734200 +0200
***************
*** 30,35 ****
--- 30,36 ----
  SYMPY_DEBUG = __sympy_debug()

  from .core import *
+ del sets
  from .logic import *
  from .assumptions import *
  from .polys import *



On Wed, Apr 9, 2014 at 10:07 AM, Andrew Ayre <andy at britishideas.com> wrote:
> OK. Is there a workaround I can use?
>
> Andy
>
> On 4/8/2014 8:04 PM, Pawel Jasinski wrote:
>> It looks like the import bug, but is different.
>> This time imported is confusing already imported:  sympy.core.sets
>> with sympy.sets. Is is looking for  sympy.sets.fancysets in sympty.core.sets
>>
>> On Tue, Apr 8, 2014 at 11:51 AM, Andrew Ayre <andy at britishideas.com> wrote:
>>> On 4/8/2014 10:28 AM, Jeff Hardy wrote:
>>>> On Tue, Apr 8, 2014 at 9:08 AM, Andrew Ayre <andy at britishideas.com> wrote:
>>>>> Thanks. Making progress... Now it can't find sympy.sets.fancysets. I've
>>>>> added the folder where the module is defined to sys.path:
>>>>>
>>>>> =============================================
>>>>>>>> sys.path.append('../../PythonLib/sympy/sets')
>>>>>
>>>>>>>> sys.path
>>>>>
>>>>> ['.', 'C:\\Users\\Andy\\Documents\\ADScript\\bin\\Debug\\Lib',
>>>>> 'C:\\Users\\Andy\\Documents\\ADScript\\bin\\Debug\\DLLs',
>>>>> 'C:\\Users\\Andy\\Documents\\ADScript\\bin\\Debug\\PythonLib',
>>>>> '../../PythonLib', '../../PythonLib', '../../PythonLib/sympy/mpmath',
>>>>> '../../PythonLib/sympy/sets']
>>>>>
>>>>>>> >from sympy.sets.fancysets import Naturals0
>>>>>
>>>>> Traceback (most recent call last):
>>>>>   File "<string>", line 1, in <module>
>>>>>   File "C:\Users\Andy\Documents\ADScript\PythonLib\sympy\__init__.py",
>>>>> line 34, in <module>
>>>>>   File
>>>>> "C:\Users\Andy\Documents\ADScript\PythonLib\sympy\assumptions\__init__.py",
>>>>> line 2, in <module>
>>>>>   File
>>>>> "C:\Users\Andy\Documents\ADScript\PythonLib\sympy\assumptions\ask.py",
>>>>> line 323, in <module>
>>>>>   File "C:\Users\Andy\Documents\ADScript\PythonLib\sympy\core\cache.py",
>>>>> line 93, in wrapper
>>>>>   File
>>>>> "C:\Users\Andy\Documents\ADScript\PythonLib\sympy\core\function.py",
>>>>> line 185, in __new__
>>>>> ImportError: No module named fancysets
>>>>> =============================================
>>>>>
>>>>> Here is what the folder structure looks like:
>>>>>
>>>>> https://github.com/sympy/sympy/tree/master/sympy/sets
>>>>
>>>> Which version of IronPython? It sure looks like the import bug, but if
>>>> you're still hitting in 2.7.5b1 then we'll have to reopen it.
>>>
>>> Jeff,
>>>
>>> Here is my sanity check:
>>>
>>> =============================================
>>>>>> sys.version
>>>
>>> '2.7.5b1 (IronPython 2.7.5b1 (2.7.0.40) on .NET 4.0.30319.18444 (32-bit))'
>>> =============================================
>>>
>>> I'm using the pre-compiled binary version.
>>>
>>> Thanks, Andy
>>>
>>> --
>>> Andy
>>> PGP Key ID: 0xDC1B5864
>>> _______________________________________________
>>> Ironpython-users mailing list
>>> Ironpython-users at python.org
>>> https://mail.python.org/mailman/listinfo/ironpython-users
>>
>>
>>
>
> --
> Andy
> PGP Key ID: 0xDC1B5864


More information about the Ironpython-users mailing list