[ mailman-Bugs-746995 ] Error creating mailing list with http://URL/mailman/create

SourceForge.net noreply at sourceforge.net
Mon Jun 16 09:01:36 EDT 2003


Bugs item #746995, was opened at 2003-06-01 12:25
Message generated for change (Comment added) made by cuzndragon
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=746995&group_id=103

Category: None
Group: None
Status: Closed
Resolution: Invalid
Priority: 5
Submitted By: Robin Cook (cuzndragon)
Assigned to: Nobody/Anonymous (nobody)
Summary: Error creating mailing list with http://URL/mailman/create

Initial Comment:
I have just install mailman and everything seems to be
working until I try to create a mailing list using the
web interface.  When I click on the create list button
I get this error below.  I couldn't find in in the FAQ
and the archives listed was a bad link.  What is set wrong?

But if I log in as mailman and run the command line
utilities to create the mailing list there aren't any
problems.

Bug in Mailman version 2.1.2

We're sorry, we hit a bug!

If you would like to help us identify the problem,
please email a copy
of this page to the webmaster for this site with a
description of what
happened. Thanks!
Traceback:

Traceback (most recent call last):
  File "/usr/share/mailman/scripts/driver", line 87, in
run_main
    main()
  File "/usr/share/mailman/Mailman/Cgi/create.py", line
55, in main
    process_request(doc, cgidata)
  File "/usr/share/mailman/Mailman/Cgi/create.py", line
217, in
process_request
    sys.modules[modname].create(mlist, cgi=1)
  File "/usr/share/mailman/Mailman/MTA/Postfix.py",
line 232, in create
    _update_maps()
  File "/usr/share/mailman/Mailman/MTA/Postfix.py",
line 53, in
_update_maps
    raise RuntimeError, msg % (acmd, status, errstr)
RuntimeError: command failed: /usr/sbin/postalias
/var/spool/mailman/data/aliases (status: 1, Operation
not permitted)



----------------------------------------------------------------------

>Comment By: Robin Cook (cuzndragon)
Date: 2003-06-16 15:01

Message:
Logged In: YES 
user_id=5208

Yes.  Permissions are correct.
-rw-rw----    1 root     mailman      2083 May 30 22:03 aliases
-rw-rw----    1 root     mailman     12288 May 30 22:03
aliases.db

And yes 
postalias and postmap are in /usr/sbin

So what else would I need to look at for configuration error?

It works when I do it manually with the command line scripts.

----------------------------------------------------------------------

Comment By: Barry A. Warsaw (bwarsaw)
Date: 2003-06-16 14:50

Message:
Logged In: YES 
user_id=12800

You either have to make sure the data/aliases and
data/aliases.db files have the right permissions (as
described in the README and INSTALL files) or your postfix
commands aren't in /usr/sbin, in which case you need to edit
those variables in your mm_cfg.py file.

IOW, this is a configuration problem, not a bug.

----------------------------------------------------------------------

Comment By: Peer Heinlein (pheinlein)
Date: 2003-06-16 08:25

Message:
Logged In: YES 
user_id=581680

It doesn`t look like a bug... You just have to set proper permissions 
to /var/spool/mailman/data/aliases. 
 
You have a file-persmission problem, that`s all. 
 
Peer 

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=746995&group_id=103



More information about the Mailman-coders mailing list