[ mailman-Bugs-878078 ] Unable to select Slevene language

SourceForge.net noreply at sourceforge.net
Fri Jan 30 21:52:04 EST 2004


Bugs item #878078, was opened at 2004-01-16 03:06
Message generated for change (Comment added) made by bwarsaw
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=878078&group_id=103

Category: Web/CGI
Group: 2.1 (stable)
>Status: Closed
>Resolution: Fixed
Priority: 5
Submitted By: Matjaz Kljun (mkljun)
Assigned to: Nobody/Anonymous (nobody)
Summary: Unable to select Slevene language

Initial Comment:
When I try to select Slovene language for the mailing list 
I get this bug report. It's odd that it happens only
with Slovene language. If I select Italian or any other
language 
it doesn't complain. 

Bug in Mailman version 2.1.4

We're sorry, we hit a bug!

If you would like to help us identify the problem,
please email a copy of this page to the webmaster for
this site with a description of what happened. Thanks!
Traceback:

Traceback (most recent call last):
  File "/usr/local/mailman/scripts/driver", line 87, in
run_main
    main()
  File "/usr/local/mailman/Mailman/Cgi/admin.py", line
175, in main
    change_options(mlist, category, subcat, cgidata, doc)
  File "/usr/local/mailman/Mailman/Cgi/admin.py", line
1296, in change_options
    gui.handleForm(mlist, category, subcat, cgidata, doc)
  File "/usr/local/mailman/Mailman/Gui/GUIBase.py",
line 158, in handleForm
    self._setValue(mlist, property, val, doc)
  File "/usr/local/mailman/Mailman/Gui/Language.py",
line 120, in _setValue
    i18n.set_language(val)
  File "/usr/local/mailman/Mailman/i18n.py", line 35,
in set_language
    language)
  File "/usr/local/lib/python2.2/gettext.py", line 248,
in translation
    t = _translations.setdefault(key,
class_(open(mofile, 'rb')))
  File "/usr/local/lib/python2.2/gettext.py", line 106,
in __init__
    self._parse(fp)
  File "/usr/local/lib/python2.2/gettext.py", line 180,
in _parse
    k, v = item.split(':', 1)
ValueError: unpack list of wrong size



Python information:

Variable	Value
sys.version	2.2.2 (#1, Jan 3 2003, 07:54:31) [GCC 3.2.1
[FreeBSD] 20021119 (release)]
sys.executable	/usr/local/bin/python
sys.prefix	/usr/local
sys.exec_prefix	/usr/local
sys.path	/usr/local
sys.platform	freebsd5

Environment variables:

Variable	Value
PATH_INFO 	/senat/language
HTTP_ACCEPT 
application/x-shockwave-flash,text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
CONTENT_TYPE 	application/x-www-form-urlencoded
HTTP_REFERER 
http://www.upr.si/mailman/admin/senat/language
SERVER_SOFTWARE 	Apache/1.3.27 (Unix) PHP/4.2.3
PYTHONPATH 	/usr/local/mailman
SCRIPT_FILENAME 	/usr/local/mailman/cgi-bin/admin
SERVER_ADMIN 	andy at upr.si
SCRIPT_NAME 	/mailman/admin
SERVER_SIGNATURE 	
Apache/1.3.27 Server at www.upr.si Port 80
REQUEST_METHOD 	POST
HTTP_HOST 	www.upr.si
HTTP_KEEP_ALIVE 	300
SERVER_PROTOCOL 	HTTP/1.1
QUERY_STRING 	
PATH_TRANSLATED 	/usr/local/www/data/senat/language
REQUEST_URI 	/mailman/admin/senat/language
CONTENT_LENGTH 	118
HTTP_ACCEPT_CHARSET 	ISO-8859-1,utf-8;q=0.7,*;q=0.7
HTTP_USER_AGENT 	Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.5) Gecko/20031007
HTTP_CONNECTION 	keep-alive
HTTP_COOKIE 
senat+admin=280200000069efdd0640732800000061346663386238616161633832333165333334373536393030393639393637303161346334396162
SERVER_NAME 	www.upr.si
REMOTE_ADDR 	193.2.97.204
REMOTE_PORT 	2967
HTTP_ACCEPT_LANGUAGE 	en-us,en;q=0.5
UNIQUE_ID 	QAbeNMECFgMAAC4QCZ8
SERVER_PORT 	80
GATEWAY_INTERFACE 	CGI/1.1
HTTP_ACCEPT_ENCODING 	gzip,deflate
SERVER_ADDR 	193.2.22.3
DOCUMENT_ROOT 	/usr/local/www/data

----------------------------------------------------------------------

>Comment By: Barry A. Warsaw (bwarsaw)
Date: 2004-01-30 21:52

Message:
Logged In: YES 
user_id=12800

I see you took out the line that says

"#-#-#-#-#  mailman.po (PACKAGE VERSION)  #-#-#-#-#\n"

Since that line seems bogus, I removed it in CVS.  Hopefully
that'll do the trick for you.  Note that this won't crash
for you if you use Python 2.2.3 or Python 2.3, because the
gettext.py module was made robust enough to ignore these errors.


----------------------------------------------------------------------

Comment By: Matjaz Kljun (mkljun)
Date: 2004-01-19 07:43

Message:
Logged In: YES 
user_id=952444

The header of mailman.po file of slovene language in version
2.1.4 is currupted. I copied the header of english version 
and inserted the slovene info and it works fine:

# Mailman
msgid ""
msgstr ""
"Project-Id-Version: mailman_new_poprn"
"POT-Creation-Date: Sat Dec 13 14:40:28 2003n"
"PO-Revision-Date: 2003-09-30 11:18+0200n"
"Last-Translator: Urska Colner <urska.colner at agenda.si>n"
"Language-Team: Sloven??ina <sl at li.org>n"
"MIME-Version: 1.0n"
"Content-Type: text/plain; charset=ISO-8859-2n"
"Content-Transfer-Encoding: 8bitn"
"X-Generator: KBabel 1.0.1n"


Thanks for your help ;)

M

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=878078&group_id=103



More information about the Mailman-coders mailing list