[ mailman-Bugs-949117 ] 2.1.5rc2 upgrade dies on corrupt qfiles

SourceForge.net noreply at sourceforge.net
Tue May 25 10:34:08 EDT 2004


Bugs item #949117, was opened at 2004-05-06 07:16
Message generated for change (Comment added) made by jmoraragweed
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=949117&group_id=103

Category: configuring/installing
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Submitted By: Brion Vibber (vibber)
Assigned to: Nobody/Anonymous (nobody)
Summary: 2.1.5rc2 upgrade dies on corrupt qfiles

Initial Comment:
Upgrading from 2.1.2 to 2.1.5rc2; a couple of the .pck files in 
qfiles/shunt were zero-length for reasons unknown.

This caused the upgrade (make install) to fail with this message:

updating old qfiles
Traceback (most recent call last):
  File "bin/update", line 780, in ?
    errors = main()
  File "bin/update", line 709, in main
    update_qfiles()
  File "bin/update", line 441, in update_qfiles
    msg, data = dequeue(filebase)
  File "bin/update", line 497, in dequeue
    msg = cPickle.load(msgfp)
EOFError
make: *** [update] Error 1

Removing the zero-length files cleared that up.

I did have one other problem; while investigating the first bit I 
dumped some info to a text file in qfiles, and the next make install 
failed with this error:

updating old qfiles
Traceback (most recent call last):
  File "bin/update", line 780, in ?
    errors = main()
  File "bin/update", line 709, in main
    update_qfiles()
  File "bin/update", line 434, in update_qfiles
    for filename in os.listdir(dirpath):
OSError: [Errno 20] Not a directory: '/home/mailman/qfiles/blork'
make: *** [update] Error 1

At least that had the filename in it. ;) Removed the file, and it 
installed/upgraded cleanly. So far so good...

----------------------------------------------------------------------

Comment By: John Mora (jmoraragweed)
Date: 2004-05-25 09:34

Message:
Logged In: YES 
user_id=605434

I have the same problem when trying to update to 2.1.5
release from Mailman version 2.1.4.

I have no zero-length files in qfiles/shunt.

My error is similar, but I'm not certain the two are
related. I'm posting it for lack of knowing better:

Updating Usenet watermarks
- nothing to update here
Nothing to do.
updating old qfiles
Traceback (most recent call last):
  File "bin/update", line 780, in ?
    errors = main()
  File "bin/update", line 709, in main
    update_qfiles()
  File "bin/update", line 441, in update_qfiles
    msg, data = dequeue(filebase)
  File "bin/update", line 497, in dequeue
    msg = cPickle.load(msgfp)
EOFError
make: *** [update] Error 1 

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=949117&group_id=103



More information about the Mailman-coders mailing list