[ mailman-Bugs-1251101 ] cgi generated pages do not produce valid html

SourceForge.net noreply at sourceforge.net
Wed Aug 3 17:25:43 CEST 2005


Bugs item #1251101, was opened at 2005-08-03 17:25
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1251101&group_id=103

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Web/CGI
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Submitted By: skripi (skripi)
Assigned to: Nobody/Anonymous (nobody)
Summary: cgi generated pages do not produce valid html

Initial Comment:
Hi,

i ran 'http://www.htmlhelp.com/cgi-bin/validate.cgi?
url=http%3A%2F%2Fv1837.vanager.
de&warnings=yes&input=yes&spider=yes&hidevalid=yes
"
against my local mailman installation and noticed:

- the cgi's do not produce a proper doctype
- the mailinglist templates are no longer html
  conform.

Possible solution:

prepend to all generated pages a DOCTYPE:
---
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//
EN" "http://www.w3.org/TR/html4/strict.dtd">
---
or 
----
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN" "http://www.w3.org/TR/html4/loose.
dtd">
---

I would prefer strict and move presentation related stuff
to css..



----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1251101&group_id=103


More information about the Mailman-coders mailing list