[ mailman-Bugs-1100786 ] base64 messages not decoded in archives

SourceForge.net noreply at sourceforge.net
Thu Jan 13 04:55:49 CET 2005


Bugs item #1100786, was opened at 2005-01-12 10:47
Message generated for change (Comment added) made by tkikuchi
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1100786&group_id=103

Category: Pipermail
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Submitted By: Arnar Birgisson (arnar)
Assigned to: Nobody/Anonymous (nobody)
Summary: base64 messages not decoded in archives

Initial Comment:
Bug 568456 has been marked out-of-date claiming that it
"will be fixed in 2.1". I believe this hasn't been
fixed. Please reopen 568456.

----------------------------------------------------------------------

>Comment By: Tokio Kikuchi (tkikuchi)
Date: 2005-01-13 03:55

Message:
Logged In: YES 
user_id=67709

Your message was properly decoded in my test site. (Sorry I
don't want to expose it to public.) You may want to set your
language charcter set as utf-8 in mm_cfg.py or your message
may not be desplayed properly. (e.g. us-ascii is assumed in
english list)


----------------------------------------------------------------------

Comment By: Arnar Birgisson (arnar)
Date: 2005-01-12 14:25

Message:
Logged In: YES 
user_id=50086

I'm using 2.1.5. I'm uploading the message with this commit,
meant to do it earlier but got called away :o)

Thank you for testing this for me, if it works with the CVS
version I'll upgrade to that and stop whining :o)

----------------------------------------------------------------------

Comment By: Tokio Kikuchi (tkikuchi)
Date: 2005-01-12 12:47

Message:
Logged In: YES 
user_id=67709

What is your mailman version? The latest CVS which I am
testing at least can decode base64 encoded plain text
message if charset and content-transfer-encoding are
properly set as MIME compliant.
I can test on my site if you can upload the original mail
message (not the HTML page).


----------------------------------------------------------------------

Comment By: Arnar Birgisson (arnar)
Date: 2005-01-12 11:46

Message:
Logged In: YES 
user_id=50086

My archive is not publically accessible, but I'l attach a
message in html format, and in plain text with all headers
(from the mbox archive).

----------------------------------------------------------------------

Comment By: Tokio Kikuchi (tkikuchi)
Date: 2005-01-12 11:41

Message:
Logged In: YES 
user_id=67709

I believe this has been fixed. Can you show us an example
message which is not decoded (scrubbed) in the archive?


----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1100786&group_id=103


More information about the Mailman-coders mailing list