[ mailman-Bugs-1268939 ] host_name tag doesn't allow IP addresses

SourceForge.net noreply at sourceforge.net
Mon Nov 14 00:59:49 CET 2005

Bugs item #1268939, was opened at 2005-08-24 12:11
Message generated for change (Comment added) made by msapiro
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: mail delivery
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Submitted By: Daniel (doolyo)
Assigned to: Nobody/Anonymous (nobody)
Summary: host_name tag doesn't allow IP addresses

Initial Comment:

I have realised that we cannot put an IP address in 
the 'host_name' tag. Normally, we can send an e-mail 
from a client to a server that doesn't have a domain 
name by just putting it's IP address into square 
brackets like this:
This works, especially if you have put the same IP 
address on the destination server in your /etc/mail/local-
host-names file on one line (for Sendmail):

Now the problem is that if we specify the IP address 
into square brackets in the 'host_name' tag, then the 
resolved hostname is returned in the e-mail address 
instead of this square brackets IP address.
I have tried several backslashes like '', [], "", %5B and %
5D but nothing does.

Square brackets are still correct to the standard, so I 
think that this is a bug.



>Comment By: Mark Sapiro (msapiro)
Date: 2005-11-13 15:59

Logged In: YES 

What version of mailman is this? Installed from source or
from rpm or other package?

In the standard installation the only .cfg file is
data/sitelist.cfg. This is provided as an aid to configuring
the site list (mailman list) because the normal site
defaults for a new list are probably not appropriate for the
site list. This file, sitelist.cfg, is intended to be used
as input to bin/config_list to actually configure the list.
Mailman itself in operation doesn't get anything from any
*.cfg file. Actual list configurations are in

So, are you just putting something in some *.cfg file and
that's it, or do you or some other custom process in your
installation actually run bin/config_list or equivalent to
transfer that information the the actual list configuration?

If in fact, you have updated the list configuration such
that the value of host_name visible on the list's General
Options in the web admin interface or visible in the output
from 'bin/config_list -o' or in the output from 'bin/dumpdb
lists/list_name/config.pck' is the bracketed numeric IP
address, and you still have the problem of it being changed,
then I think it must be your outgoing MTA that is changing
it, not Mailman. As far as I can tell, Mailman always uses
the list's host_name attribute as the domain for email
addresses. The only exception is for the site list in some
cases where the email domain is obtained from the
VIRTUAL_HOSTS dictionary which is built by add_virtualhost()
directives in Defaults.py/mm_cfg.py.

If you have not actually changed the list's host_name
attribute because you've only changed some .cfg file and
nothing more, then you need to actually update the list.


Comment By: Daniel (doolyo)
Date: 2005-11-09 01:34

Logged In: YES 

The 'host_name' tag I am speaking about is in 
the /etc/mailman/*.cfg file (or /var/lib/mailman/data/*.cfg).
I can make the host_name accept the squared brackets IP 
address without any problem. It stays there and it is properly 
placed in the file, it is not changed.

However, when I send an e-mail to the list itself, then the e-
mail is indicated to come from 'myhost.mydomain.com' 
instead of keeping '[]'.
That is my problem, because I would like people to be able to 
answer to this IP address instead of the host name, as this 
host name is not yet active due to the fact that I am 
configuring Mailman and testing it. Once it passes my tests, 
then the domain will be active, but I need this 'from' header 
containing this exact same '[]' string 
than 'host_name' for the system to receive back the e-mails.

Kind regards,


Comment By: Mark Sapiro (msapiro)
Date: 2005-11-08 17:14

Logged In: YES 

Can you be more specific?

I have tested both Mailman 2.1.5 and 2.1.6 and they accept a
host_name of the form [] on the General Options
page with no problem.

Is your issue that you can't get General Options to accept a
numeric IP in square brackets, or that it is accepted, but
it gets 'changed' somewhere else. Please clarify, and if the
latter, please be specific about where you observe the 'change'.


You can respond by visiting: 

More information about the Mailman-coders mailing list