[ mailman-Bugs-1532638 ] can't unsub addr with double-at

SourceForge.net noreply at sourceforge.net
Wed Aug 2 06:21:41 CEST 2006


Bugs item #1532638, was opened at 2006-08-01 11:40
Message generated for change (Comment added) made by thenoob2
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1532638&group_id=103

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: (un)subscribing
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Submitted By: Cameron (thenoob2)
Assigned to: Nobody/Anonymous (nobody)
Summary: can't unsub addr with double-at

Initial Comment:
Mailman version 2.1.8.  Python 2.4.1 as shipped in
Mandriva 2006.

One of our list owners mass-subscribed an address with
the at-sign doubled.  fubar@@example.net.

That pattern should be added to whatever input
sanitization mass-subscribe uses.

Once it was in there, he tried to mass unsubscribe it.
 Which failed, and caused a nightly error mailed to the
mailman user.  

Traceback (most recent call last):
  File "bin/remove_members", line 186, in ?
    main()
  File "bin/remove_members", line 176, in main
    admin_notif, userack)
  File "/u/m/mcal/run/Mailman/MailList.py", line 1014,
in ApprovedDeleteMember
    self.removeMember(emailaddr)
  File "/u/m/mcal/run/Mailman/OldStyleMemberships.py",
line 220, in removeMember
    self.__assertIsMember(member)
  File "/u/m/mcal/run/Mailman/OldStyleMemberships.py",
line 113, in __assertIsMember
    raise Errors.NotAMemberError, member
Mailman.Errors.NotAMemberError: fubar@

The bad address shows up in Membership Management but
you can't do anything with it.  Its mail gets disabled
for excessive bouncing.

Not knowing how to drive bin/config_list, my workaround
was Perl edit in place on the pickle.
 perl -pi -e 's/fubar\@\@/fubar\@x/g' list/config.pck
and then I could remove fubar at xexample.net with
bin/remove_members.  Ugly, eh?

I wonder if this is the same bug as 551730.


Thanks for working on this,
Cameron


----------------------------------------------------------------------

>Comment By: Cameron (thenoob2)
Date: 2006-08-01 21:21

Message:
Logged In: YES 
user_id=1207635

It's possible the bad address has been in there since before
we upgraded from 2.1.6 to 2.1.8.

I don't know how it got subscribed.  These are very small
lists (25 subscribers on this one) and most subscriptions
are by the list owner through the Web interface.  But the
system was installed at 2.1.6.

>Have you tried checking 'unsub' on the admin
>membership list and 'Submit Your Changes'?

Yes that is the second thing I tried, after
bin/remove_members (as the mailman user) threw
the error shown.  Result was a red error message
at the top of the new form, something like
can't mass unsubscribe a non-subscribed address.

I've used bin/withlist to move a list from one
virtual domain to another.  That procedure is
documented in the comments at the top of
bin/fix_url.py.  I'll try it next time I have
a broken list.  Thanks.


----------------------------------------------------------------------

Comment By: Mark Sapiro (msapiro)
Date: 2006-08-01 14:19

Message:
Logged In: YES 
user_id=1123998

Have you tried checking 'unsub' on the admin membership list
and 'Submit Your Changes'?

If that doesn't work, see
http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq03.013.htp
for the 'withlist' method.

For what it's worth, I tried mass subscribing
msapiro@@value.net with both the distribution 2.1.5 and my
2.1.8+ working copy and I get "Bad/Invalid email address".

Are you sure this is how the subscribe was done?


----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1532638&group_id=103


More information about the Mailman-coders mailing list