[ mailman-Bugs-1531675 ] ARCHIVE_TO_MBOX=1 broken

SourceForge.net noreply at sourceforge.net
Mon Jul 31 13:23:42 CEST 2006

Bugs item #1531675, was opened at 2006-07-31 11:23
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: configuring/installing
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Ross Golder (rossigee)
Assigned to: Nobody/Anonymous (nobody)
Summary: ARCHIVE_TO_MBOX=1 broken

Initial Comment:
While looking into an archiving problem on
mail.gnome.org, where we use our own external archiver
(ARCHIVE_TO_MBOX was set to 1), Owen Taylor discovered
the following bug causing it to ignore this setting:

>From /usr/lib/mailman/Mailman/Defaults.py:

#-1 - do not do any archiving
# 0 - do not archive to mbox, use builtin mailman html
archiving only
# 1 - archive to mbox to use an external archiving
mechanism only
# 2 - archive to both mbox and builtin mailman html
archiving -
#     use this to make both external archiving
mechanism work and
#     mailman's builtin html archiving.  the flat mail
file can be
#     useful for searching, external archivers, etc.

Now, while that's not particularly clear, I can
certainly see why one might assume that we wanted a
setting, of '1', but if you look at the code we see:

        if mm_cfg.ARCHIVE_TO_MBOX in (1, 2):
            if mm_cfg.ARCHIVE_TO_MBOX == 1:
                # Archive to mbox only.
        txt = str(msg)
        # should we use the internal or external archiver?

So, ARCHIVE_TO_MBOX=1 skips both the internal *and*
external archivers, and archives only to the MBOX files.


You can respond by visiting: 

More information about the Mailman-coders mailing list