[ mailman-Bugs-1562922 ] "Discard all...Defer" button appears on mod. detail page

SourceForge.net noreply at sourceforge.net
Thu Sep 21 20:28:59 CEST 2006


Bugs item #1562922, was opened at 2006-09-21 08:05
Message generated for change (Comment added) made by msapiro
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1562922&group_id=103

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Web/CGI
Group: 2.1 (stable)
>Status: Closed
>Resolution: Fixed
Priority: 5
Submitted By: Dan Astoorian (djast)
Assigned to: Nobody/Anonymous (nobody)
Summary: "Discard all...Defer" button appears on mod. detail page

Initial Comment:
This is a clarification and restatement of bug
#1000699, which was marked "closed" but describes a bug
which is still present.

On the admindb pages, there is a checkbox labelled
"Discard all messages marked Defer" near each of the
submit buttons at the top and bottom of the page.  This
checkbox appears on the default admindb page (where the
requests are grouped by sender), and also on the
"?details=all" page (which is reached by following the
"You can also view the details of all held postings" link).

The checkboxes have no effect on the "?details=all"
page (because the form is structured differently from
the default admindb page).

The comments in Bug #1000699 says that "the 'discard
all deferred' checkbox was intended to work only on the
summary page. It's appearance on the detail pages was a
mistake that was fixed in 2.1.6"; from this I assume
that the checkboxes are not supposed to appear on the
"?details=all" page, but they're still there.

The test in Cgi/admindb.py for whether to supply the
button is "if not (sender or msgid):"; perhaps the test
should be changed to something like "if not (details or
sender or msgid):".

(I mentioned this in a comment I attached to closed bug
#1000699, but there's been no further discussion, and
the bug is still present as of 2.1.9.)


----------------------------------------------------------------------

>Comment By: Mark Sapiro (msapiro)
Date: 2006-09-21 11:28

Message:
Logged In: YES 
user_id=1123998

Your comment on bug # 1000699 slipped through the cracks.
I'm sorry.

This has now been fixed as you suggest in subversion on both
the trunk and the Release_2_1-maint branch.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1562922&group_id=103


More information about the Mailman-coders mailing list