[ mailman-Bugs-1792087 ] Mailman changes attachment filenames

SourceForge.net noreply at sourceforge.net
Mon Sep 17 01:16:53 CEST 2007

Bugs item #1792087, was opened at 2007-09-10 20:58
Message generated for change (Comment added) made by madrobin
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: mail delivery
Group: 2.1 (stable)
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Steven (madrobin)
Assigned to: Nobody/Anonymous (nobody)
Summary: Mailman changes attachment filenames

Initial Comment:

I'm using Mailman version 2.1.9.cp2, hosted by site5.com.

When sending attachments with long filenames to a list, the file name arrives with one character substituted for another. The attachments with the changed filename cannot be opened in the FirstClass email client.

The attachment names were:

2007 September Using FirstClass To Book School Resources.pdf


2007 September Teaching Lab Expectations and Routines.pdf

In both cases, when the attachment filenames were viewed in FirstClass after having been delivered by Mailman, the last space in the filename had been converted to a character which looks like a square. I am attaching a screenshot.

If I try to open the attachment in FirstClass, I receive an error dialog box:

File Transfer Failed because 

File not open error


I am not able to open the attachment.

If I send the same attachments with the same filenames "directly" (not through Mailman) and open them in FirstClass, there is no problem. The filenames do not change and the attachments can be opened without difficulty.

If I shorten the attachment filenames (for example, I removed the "2007 September" part of the above filenames) and send them through Mailman, there is also no problem; the filenames do not change and the attachments can be opened.

I also tried viewing the long-filename attachments sent via Mailman in a different email client (Pegasus Mail). The attachment filenames had again been changed (instead of a square, the character which had been substituted for the last space looked more like a thick vertical bar.) However, even with the filename change, Pegasus Mail was still able to open the attachments. (Unfortunately, my employer allows us to use only FirstClass.)

I was not able to find anything addressing this problem. However, if I missed it and you can point me in the direction of a solution, I would greatly appreciate it.

Thank you.


>Comment By: Steven (madrobin)
Date: 2007-09-16 19:16

Logged In: YES 
Originator: YES


Thanks very much for your reply. I have tried your suggestions about
renaming the attachments in FirstClass, but it does not seem to be
possible. If I try to "save" rather than "open" the attachments, I get an
immediate "file input/output error" and that's that.

I would be able to send you a copy of the "internet headers" from the
message as it was received in FirstClass, as well as the headers of the
copy of the message which I saved in Pegasus Mail when the message was
being sent. Is this what you need? I'm not sure that this is something I
would want to post in a public forum. Can I email them to you?

Thanks again for your help.


Comment By: Mark Sapiro (msapiro)
Date: 2007-09-10 21:31

Logged In: YES 
Originator: NO

This appears to be a problem with header folding and unfolding resulting
in the <space> being possibly replaced by a <tab> which is shown as an
'invalid character' (the square symbol) by the mail client.

Can you save the attachment and then open the saved file outside of
FirstClass (perhaps after changing it's name or 'saving as' and providing a
'good' name)?

I am unable to know what is at fault here without seeing the raw headers
of the attachment part from the mail as sent and the mail as received from

It may be a Mailman issue, a cPanel issue or a FirstClass issue.

Also, please see


You can respond by visiting: 

More information about the Mailman-coders mailing list