[ mailman-Bugs-1996767 ] Authorization failed using FF3 (Win32)

SourceForge.net noreply at sourceforge.net
Mon Jul 21 13:55:30 CEST 2008


Bugs item #1996767, was opened at 2008-06-18 09:12
Message generated for change (Comment added) made by realriot
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1996767&group_id=103

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Web/CGI
Group: 2.1 (stable)
Status: Closed
Resolution: Works For Me
Priority: 5
Private: No
Submitted By: realriot (realriot)
Assigned to: Nobody/Anonymous (nobody)
Summary: Authorization failed using FF3 (Win32)

Initial Comment:
Today, 1 day after the release of FireFox 3 I'm trying to login to my mailman 2.1.10. After entering the correct password the errormessage "Authorization failed" is shown. Deleting the Browser Cache/Cookies didn't fix the problem.

There's no problem logging in with Firefox 2 or IE7. All other tested browsers work, too. Except FireFox 3.

----------------------------------------------------------------------

>Comment By: realriot (realriot)
Date: 2008-07-21 13:55

Message:
Logged In: YES 
user_id=2121701
Originator: YES

Today I've found the problem. The problem consists of "copy & paste".

- I got an email with a password to enter
- I copied this password with a double-click and STRG-C
- I pasted the password in the password field
- Clicked OK and got the message "wrong password".

Now I tried the following:

- I marked the whole password from the right to the left
- Copied it with STRG-C
- And pasted it
- Successfully logged in

Seems, that FF3 additionally uses a "\n" with the password or something
like that. FF2 didn't react this way. Is there any way to disable this
behaviour? It's very strange to use copy&paste for passwords now.

----------------------------------------------------------------------

Comment By: SourceForge Robot (sf-robot)
Date: 2008-07-18 04:20

Message:
Logged In: YES 
user_id=1312539
Originator: NO

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

----------------------------------------------------------------------

Comment By: realriot (realriot)
Date: 2008-06-20 08:18

Message:
Logged In: YES 
user_id=2121701
Originator: YES

Seems to be a cookie problem (or something like that). If I login with
directly giving the pass (adminpw=foobar) it works... Entering the password
at the password prompt the login fails...

----------------------------------------------------------------------

Comment By: Mark Sapiro (msapiro)
Date: 2008-06-20 03:29

Message:
Logged In: YES 
user_id=1123998
Originator: NO

I second Barry's comment. I have no problems with FireFox 3 on Win XP or
Mac OS X.

----------------------------------------------------------------------

Comment By: Barry A. Warsaw (bwarsaw)
Date: 2008-06-19 23:22

Message:
Logged In: YES 
user_id=12800
Originator: NO

I've been using FF3 on both OS X and Ubuntu and have had no problems
interacting with any of the mailing lists.  I think we'll need more
information in order to help you.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=1996767&group_id=103


More information about the Mailman-coders mailing list