[Bug 646344] [NEW] 2.1.14 GUI crash: ALLOW_SENDER_OVERRIDES AttributeError

Brent 646344 at bugs.launchpad.net
Thu Sep 23 22:46:03 CEST 2010

Public bug reported:

I just upgraded to 2.1.14 from 2.1.12.  When trying to login to the
admin interface for a list, Mailman crashes and I get a "bug" message in
the browser.  The Mailman error log contains this:

admin(24739):   PYTHONPATH: /opt/mailman 
admin(24739):   SCRIPT_FILENAME: /opt/mailman/cgi-bin/admin 
admin(24739):   SERVER_ADMIN: [edited out]
admin(24739):   HTTP_HOST:  [edited out]
admin(24739):   HTTPS: on 
admin(24739):   HTTP_CONNECTION: keep-alive 
admin(24739):   HTTP_CACHE_CONTROL: max-age=0 
admin(24739):   REQUEST_URI: /mailman/admin/[edited out] 
admin(24739):   HTTP_ACCEPT: application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 
admin(24739):   GATEWAY_INTERFACE: CGI/1.1 
admin(24739):   REMOTE_PORT: 36978 
admin(24739):   HTTP_ACCEPT_LANGUAGE: en-us 
admin(24739):   CONTENT_TYPE: application/x-www-form-urlencoded 
admin(24739):   HTTP_ACCEPT_ENCODING: gzip, deflate 
admin(24739):   UNIQUE_ID: TJuulolSrxMAAGCeOtwAAAAA 
Sep 23 12:47:11 2010 admin(24744): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ 
admin(24744): [----- Mailman Version: 2.1.14 -----] 
admin(24744): [----- Traceback ------] 
admin(24744): Traceback (most recent call last):
admin(24744):   File "/opt/mailman/scripts/driver", line 112, in run_main
admin(24744):     main()
admin(24744):   File "/opt/mailman/Mailman/Cgi/admin.py", line 175, in main
admin(24744):     change_options(mlist, category, subcat, cgidata, doc)
admin(24744):   File "/opt/mailman/Mailman/Cgi/admin.py", line 1299, in change_options
admin(24744):     gui.handleForm(mlist, category, subcat, cgidata, doc)
admin(24744):   File "/opt/mailman/Mailman/Gui/GUIBase.py", line 144, in handleForm
admin(24744):     for item in self.GetConfigInfo(mlist, category, subcat):
admin(24744):   File "/opt/mailman/Mailman/Gui/General.py", line 418, in GetConfigInfo
admin(24744):     if mm_cfg.ALLOW_SENDER_OVERRIDES:
admin(24744): AttributeError: 'module' object has no attribute 'ALLOW_SENDER_OVERRIDES'
admin(24744): [----- Python Information -----] 
admin(24744): sys.version     =   2.4.4 (#1, Jan  9 2007, 23:31:33) [C] 
admin(24744): sys.executable  =   /usr/bin/python 
admin(24744): sys.prefix      =   /usr 
admin(24744): sys.exec_prefix =   /usr 
admin(24744): sys.path        =   ['/opt/mailman/pythonlib', '/opt/mailman', '/opt/mailman/scripts', '/opt/mailman', '/usr/lib/python24.zip', '/usr/lib/python2.4/', '/usr/lib/python2.4/plat-sunos5', '/usr/lib/python2.4/lib-tk', '/usr/lib/python2.4/lib-dynload', '/usr/lib/python2.4/site-packages'] 
admin(24744): sys.platform    =   sunos5 


By editing the /Mailman/Gui/General.py file (line 418) and removing the
offending section, I'm able to login to and use the admin area.
However, it's clearly also removing some functionality:

# Suppression of Sender header modification
#    rtn.append(
#        ('include_sender_header', mm_cfg.Radio,
#         (_('No'), _('Yes')), 0,
#         _("""Should the <tt>Sender</tt> header be rewritten for this
#         mailing list to avoid stray bounces?  <em>Yes</em> is
#         recommended."""),

#         _("""<a href="http://www.faqs.org/rfcs/rfc2822.html">RFC
#         2822</a> defines the <tt>Sender</tt> header and defines it
#         as "the mailbox of the agent responsible for the actual
#         transmission of the message."  Mailman replaces this header
#         by default with the list's bounce address.

#         <p>While it is debatable if Mailman is such an agent, setting
#         this header helps directing bounces from some broken MTAs to
#         the right destination.  On the other hand, some mail
#         readers show unexpected behaviour if this header is set (like
#         missing addresses in forwarded mails and copies sent to the
#         bounce address on reply-to-all), so it can be disabled
#         here."""))
#        )

** Affects: mailman
     Importance: Undecided
         Status: New

2.1.14 GUI crash: ALLOW_SENDER_OVERRIDES AttributeError
You received this bug notification because you are a member of Mailman
Coders, which is subscribed to GNU Mailman.

More information about the Mailman-coders mailing list