[Bug 1073506] [NEW] Drop support for Python 2.6

Barry Warsaw 1073506 at bugs.launchpad.net
Wed Oct 31 11:19:23 CET 2012


Public bug reported:

Whenever the dependency stack is ported to Python 3, Mailman 3 will be
ported to Python 3.  In the meantime, making the code Python 2.7 -3
clean is an intermediate step toward Python 3 support.  In order to do
this, we really need to drop Python 2.6 support and this will also allow
us to improve the test suite, as well as other code improvements.
Besides, Python 2.6 is 4 years old and in security-only maintenance
mode, while Python 2.7 is stable and still supported for bug fixes.

** Affects: mailman
     Importance: High
     Assignee: Barry Warsaw (barry)
         Status: In Progress


** Tags: mailman3

** Changed in: mailman
       Status: New => Triaged

** Changed in: mailman
   Importance: Undecided => High

** Changed in: mailman
     Assignee: (unassigned) => Barry Warsaw (barry)

** Changed in: mailman
    Milestone: None => 3.0.0b3

** Tags added: mailman3

** Changed in: mailman
       Status: Triaged => In Progress

-- 
You received this bug notification because you are a member of Mailman
Coders, which is subscribed to GNU Mailman.
https://bugs.launchpad.net/bugs/1073506

Title:
  Drop support for Python 2.6

To manage notifications about this bug go to:
https://bugs.launchpad.net/mailman/+bug/1073506/+subscriptions


More information about the Mailman-coders mailing list