[Bug 1609516] Re: [needs-packaging] GNU Mailman v3

Kẏra 1609516 at bugs.launchpad.net
Wed Aug 3 14:41:06 EDT 2016


** Description changed:

- Mailman 3 is essentially five projects:
+ Mailman 3 is really a suite of 5 tools:
  
- Mailman Core
- Postorius - The Web UI for Mailman
- Mailman Client - The REST API Client
- HyperKitty - The Archiver for Mailman
- Mailman Bundler - Installer for Mailman Suite including all above projects
+  * The core, which provides the mail delivery engine, the unified user
+ model, moderation and modification of email messages, and interfaces to
+ external archivers;
  
- URL: https://www.gnu.org/software/mailman/
+  * Postorius, our new Django-based web user interface for users and list
+    administrators;
+ 
+  * HyperKitty, our new Django-based web archiver, providing rich access
+ to the historical record of mailing list traffic;
+ 
+  * mailman.client, the official Python bindings to the core's REST API;
+ 
+  * mailman-bundler, a set of scripts to make it easy to deploy the full
+    suite inside Python virtual environments.
+ 
+ What's new about Mailman 3?  Well, lots!  Some highlights include:
+ 
+  * Backed by a relational database;
+ 
+  * True support for multiple domains, with no cross-domain mailing list
+ naming restrictions;
+ 
+  * One user account to manage all your subscriptions on a site;
+ 
+  * The core's functionality exposed through an administrative REST+JSON
+ API;
+ 
+  * All passwords hashed by default, and no monthly password reminders!
+ 
+  * Users can post to lists via the web interface;
+ 
+  * Built-in archive searching!
+ 
+ and more.  Tons more.

** Bug watch added: hacking a member #1363871
   https://bugzilla.redhat.com/cgi-bin/bugreport.cgi?bug=1363871

** Also affects: fedora via
   https://bugzilla.redhat.com/cgi-bin/bugreport.cgi?bug=1363871
   Importance: Unknown
       Status: Unknown

-- 
You received this bug notification because you are a member of Mailman
Coders, which is subscribed to GNU Mailman.
https://bugs.launchpad.net/bugs/1609516

Title:
  [needs-packaging] GNU Mailman v3

To manage notifications about this bug go to:
https://bugs.launchpad.net/mailman/+bug/1609516/+subscriptions


More information about the Mailman-coders mailing list