[Bug 1740543] Re: Mailman 2.1.22+ requires Python 2.7

Mark Sapiro mark at msapiro.net
Fri Dec 29 16:02:27 EST 2017


** Description changed:

  While we have been strongly recommending Python 2.7 for some time, it
  has not been listed as a requirement. Mailman 2.1.22 introduced a call
  to re.sub() with a flags= argument that requires Python 2.7. The code in
  question will only be executed when archiving a message with no Date:
- header containing a valid date and no X-List-Received-At: header
+ header containing a valid date and no X-List-Received-Date: header
  containing a valid date which will almost certainly only occur when
  bin/arch is processing a mbox containing such a message, so this is of
  minor importance, but is easily fixed so I'll fix it.

** Changed in: mailman
       Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Mailman
Coders, which is subscribed to GNU Mailman.
https://bugs.launchpad.net/bugs/1740543

Title:
  Mailman 2.1.22+ requires Python 2.7

To manage notifications about this bug go to:
https://bugs.launchpad.net/mailman/+bug/1740543/+subscriptions


More information about the Mailman-coders mailing list