[Bug 1666390] [NEW] SpamAssassin documentation missing step from patch file

Jeremy 1666390 at bugs.launchpad.net
Mon Feb 20 23:57:11 EST 2017


Public bug reported:

This page gives a few methods for using SpamAssassin with mailman: https://wiki.list.org/DOC/4.23%20How%20do%20I%20use%20SpamAssassin%20with%20Mailman%3F
The second methods links to a set of instructions (http://www.jamesh.id.au/articles/mailman-spamassassin/) and then gives some additional steps to take.

There are two different patch files given that you need apply to
SpamAssassin.py to integrate SpamAssassin with mailman, depending on
what version. The second one (just after "And beginning with Mailman
2.1.21, the following patch is required instead of the above.") isn't
complete, there is an old import that needs to be deleted that isn't
mentioned.

Specifically, line 31, `from Mailman.Handlers.Moderate import matches_p`
needs to be deleted.


I just went through the instructions and it took a bit of debugging to find where the error logs were, and what the problem was.

** Affects: mailman
     Importance: Undecided
         Status: New


** Tags: documentation

-- 
You received this bug notification because you are a member of Mailman
Coders, which is subscribed to GNU Mailman.
https://bugs.launchpad.net/bugs/1666390

Title:
  SpamAssassin documentation missing step from patch file

To manage notifications about this bug go to:
https://bugs.launchpad.net/mailman/+bug/1666390/+subscriptions


More information about the Mailman-coders mailing list