[Mailman-Developers] Python 1.5 compatible ? no!

Christian Tismer tismer@appliedbiometrics.com
Wed, 02 Sep 1998 03:05:51 +0200

Today I spent a couple of hours trying to get Mailman b5 running on
the starship. Starship has Python 1.5 at the moment (for whatever
reason), and the INSTALL file claims

    You must have the Python interpreter installed somewhere on your
    system.  Currently Python 1.5 or later is required.  For
    information about obtaining Python source code, or pre-compiled
    binaries please see the Python Web site at

This is not true. This version will not even run with a standard 1.5.1

Killer#1: The parameter-less "raise" statement is no 1.5.1 feature.
Killer#2: The __stdin__ and other underscored system file names
are no Python 1.5 features.

This together makes the "scripts/driver" file die very early, with
a confusing error message.

In the driver script, I inserted this before any code:

    import sys

... Uhm, I'm hacking since 6 hours now, but don't get the list admin
running under Linux. I fear I will turn back to 0.95 which worked.

tired - pirx

Christian Tismer             :^)   <mailto:tismer@appliedbiometrics.com>
Applied Biometrics GmbH      :     Have a break! Take a ride on Python's
Kaiserin-Augusta-Allee 101   :    *Starship* http://starship.skyport.net
10553 Berlin                 :     PGP key -> http://pgpkeys.mit.edu
     we're tired of banana software - shipped green, ripens at home