[Mailman-Developers] Membership management chunking requires two authentications..

Ricardo Kustner ricardo@rixhq.nu
Mon, 21 Feb 2000 22:15:18 +0100

On Mon, Feb 21, 2000 at 01:56:52PM -0600, Ted Cabeen wrote:
> I don't know if this has been fixed in the CVS version, but I thought I'd 
> submit it anyways.  There seems to be a small authentication bug with the 
> chunking in the membership management page.  The page will load up correctly 
> the first time it is accessed with the first chunk size shown.  However, when 
> you request a different chunk, it requires a reauthentication and then gives 
> the chunk=0 page instead of the requested chunk.  If you then click on the 
> alternate chunk it loads fine.  However, the additional click and 
> authentication is annoying. 

I have/had the same problem, and i'm using the CVS version...

I just had a closer look and now I know why it behaves this way in my case:
our list is accessible at two hostnames which share the exact same website...
the hostname that is linked at the membership chunk links is different
than the hostname i sometimes use to access the list... so netscape thinks
the cookie is for a different host...

which makes me wonder why the chunk links on the admin page have a full
http:// link while other links on it don't ?

maybe you are experiencing the same problem? compare the hostname you
use to access the admin page with the hostname that's being used in the 
links to the membership chunks... if they are different, that's the
reason why you have to re-enter the password.