[Mailman-Developers] Getting wrapped up in wrapper

Scott Brown scott-brown@home.com
Sat, 6 Jan 2001 21:50:06 -0500


Does wrapper only work for python modules or can I call other (ie, perl)
modules from it?

I've tried to pass thru wrapper into a perl script, but I've been getting
(among other things)

   ----- Transcript of session follows -----
Illegal command: /home/webmaster/readmsg.pl
554 "|/home/mailman/mail/wrapper /home/webmaster/readmsg.pl"... unknown
mailer error 6

I've tried changing the pipe to

"|perl /home/webmaster/readmsg.pl" - but perl cant read the script because
it's got root:root permissions (I need them if I'm going to be updating
/etc/aliases)

I've also tried going straight to the "|/home/webmaster/readmsg.pl" - but I
get a permissions error that I cant figure out since the script is set to
set uid when executed (and as I mentioned, it is a root:root)

   ----- Transcript of session follows -----
sh: /home/webmaster/readmsg.pl: Permission denied
554 "|/home/webmaster/readmsg.pl"... unknown mailer error 126

Any help/experience/pointers to FAQs on passing off msgs from sendmail to
perl scripts would be appreciated.

(BTW: sendmail is an old 8.5 version... perl is 5.004 - and no, I cant
upgrade either right now...)

Thanks
Scott.