[Mailman-Developers] [ mailman-Bugs-230400 ] German Umlaute mess up subject-line and body

noreply@sourceforge.net noreply@sourceforge.net
Fri, 23 Aug 2002 15:30:57 -0700


Bugs item #230400, was opened at 2001-01-29 11:49
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=230400&group_id=103

Category: mail delivery
>Group: 2.0.x
>Status: Closed
>Resolution: Out of Date
Priority: 5
Submitted By: Thomas Franosch (tfra)
Assigned to: Nobody/Anonymous (nobody)
Summary: German Umlaute mess up subject-line and body

Initial Comment:
These characters (, ,  and probably even others) in the subject-line lead to a multiplication of the [listname] and Re: when one replies to such a mail. This is not because of a crapy mailer. The more replies, the longer the subject-line gets (if the author doesn not delete it manually). The characters in the subject-line actually get displayed correctly. Unfortunately, the use of them in the body leads to an unreadable mess as has already been posted here earlier.
Needless to say that both these phenomenons are very annoying for actually at least every German list that runs mailman!

----------------------------------------------------------------------

>Comment By: Barry A. Warsaw (bwarsaw)
Date: 2002-08-23 18:30

Message:
Logged In: YES 
user_id=12800

I believe all this stuff works much better in the latest
MM2.1 betas.  Please resubmit a bug report if you find
problems with MM2.1

----------------------------------------------------------------------

Comment By: Johan Holmberg (holmberg)
Date: 2001-05-08 17:43

Message:
Logged In: YES 
user_id=215003

The problems with non-ASCII characters in the Subject line
can be fixed by applying my patch:

....[ #422468 ] Avoid multiple prefixes in Subject

/Johan Holmberg



----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100103&aid=230400&group_id=103