[Mailman-Developers] Unable to install 2.1b5 on RedHat 7.3

Liam Routt liam at routt.net
Sat Dec 7 07:43:20 EST 2002

I'm new to the list (although I've been using 2.0x for a while now).

I'm trying to install 2.1b5 on a RedHat 7.3 system, and having no luck. 
Some pertinent info:

RedHat 7.3 i386
Comes with python 1.5.2 installed
also installed python2 (python 2.2)
Have qmail installed in place of sendmail (although sendmail rpm is in 

The error I'm getting is one I have seen mention of before in the 

Compiling /home/mailman/Mailman/versions.py ...
Traceback (most recent call last):
  File "bin/update", line 44, in ?
    import paths
  File "bin/paths.py", line 55, in ?
    import japanese
ImportError: No module named japanese

The solution was supposed to have to do with setting the permissions 
pythonlib and its contents, I believe. I fiddled around trying to make 
sure that was being done, but noticed that pythonlib was empty.

That ends up being the actual problem I'm having. The packages which are 
supposed to be in pythonlib are not put there. The reason is buried back 
in the earlier part of the installation (and I don't have the output to 
hand at the moment). In short, the misc/Makefile.in (where the packages 
are to be installed and the permissons set correctly) is unable to 
recognize my python installation.

At first I was leaving things as they installed on my machine, with python 
1.5.2 in the path as "python" and using the --with-python directive to 
point to "python2". When I worked out what was going wrong I mv'd python 
out of the way and put a link to "python2" from "python" and tried again, 
but it had the same effect (ie it was unable to recognize the python 2.2 
installation). After that I put python 1.5.2 back where it belonged and 
tried the installation without the --with-python, and that had the same 

What I recall is that it was looking for a particular file (a config file 
of some sort) in a directory that does exist. The file is not there, 
although a lot of other python packages and files are.

Things to consider:

1. The failure did not halt the install, although it did make it 
impossible for it to complete. But the relevant messages were *way* back, 
and probably meaningless to a non-technical person, at a guess.

2. How should mailman recognize this python 2.2 installation as used in 
RedHat 7.3 (and earlier, at least). Without removing my older python 
(which there are a lot of apparent dependencies on) and installing from 
the src, I can't see any other way to get python 2.2 easily installed.

3. Any suggestions what I should try?

Take care,

Liam Routt                                               liam@routt.net
Darcsyde Productions                     http://www.routt.net/Caligari/

        -- still waiting for the Absolute Destiny Apocalypse --

More information about the Mailman-Developers mailing list