[Mailman-Developers] can't resolve "smrsh: mailman not available for sendmail programs" issue

Keith Steward ksteward at keithsteward.com
Sun Dec 29 13:31:35 EST 2002


After several attempts to get Mailman installed (including stable 2.0 
final, and newest 2.1rc1), and hitting unresolvable "smrsh: mailman not 
available for sendmail programs" issues (despite trying numerous 
things), i'm just about ready to give up.

I've been able to get Mailman to send  email to a new subscriber asking 
for confirmation, and the /var/log/maillog shows the response to the 
subscriber's confirmation email, but ALWAYS reporting the damn smrsh 
-------- /var/log/maillog segment ------------
sendmail[30785]: gBTEUjD30785: from=<ksteward at keithsteward.com>, 
size=2749, class=0, nrcpts=1, 
proto=ESMTP, daemon=MTA, relay=steward-family.com []
smrsh: uid 8: attempt to use mailman request test1
sendmail[30786]: gBTEUjD30785: to="|/etc/smrsh/mailman request test1", 
ctladdr=<test1-request at justice4injuredworkers.org> (8/0), 
delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=31743, dsn=5.0.0, 
stat=Service unavailable
sendmail[30786]: gBTEUjD30785: gBTEUjD30786: DSN: Service unavailable
sendmail[30786]: gBTEUjD30786: to=<ksteward at keithsteward.com>, 
delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=31843, 
relay=keithsteward.com. [], dsn=2.0.0, stat=Sent 
(gBTERt820385 Message accepted for delivery)
----------- end segment ---------------

*System information:*
RedHat 7.2, Sendmail 8.11.6, Python-2.2.2
The /etc/aliases includes:
## test1 mailing list
test1:              "|/etc/smrsh/mailman post test1"
test1-admin:        "|/etc/smrsh/mailman admin test1"
test1-bounces:      "|/etc/smrsh/mailman bounces test1"
test1-confirm:      "|/etc/smrsh/mailman confirm test1"
test1-join:         "|/etc/smrsh/mailman join test1"
test1-leave:        "|/etc/smrsh/mailman leave test1"
test1-owner:        "|/etc/smrsh/mailman owner test1"
test1-request:      "|/etc/smrsh/mailman request test1"
test1-subscribe:    "|/etc/smrsh/mailman subscribe test1"
test1-unsubscribe:  "|/etc/smrsh/mailman unsubscribe test1"
Sendmail can send and receive successfully from a regular (non-Mailman) 
account on the machine running Mailman.
newaliases was run after the above aliases were added.
/etc/smrsh contains:
 lrwxrwxrwx    1 root     root           31 Dec 29 05:38 mailman -> 
The permissions on the /usr/local/mailman/mail/mailman wrapper are:
 -rwxr-sr-x    1 mailman  mailman     39593 Dec 29 05:16 mailman

*Things i've tried:*

   1. ./configure --with-mail-gid=mail
   2. path to mailman wrapper in /etc/aliases as either
      '/usr/local/mailman/mail/mailman' or '/etc/smrsh/mailman'
   3. ln -s /etc/smrsh/mailman /usr/local/mailman/mail/mailman
   4. copying the compiled wrapper (/usr/local/mailman/mail/mailman)
      into /etc/smrsh
   5. changing uid/gid of the wrapper to mailman, to mail
   6. by-passing sendmail as a test as in: echo "confirm" |
      /etc/smrsh/mailman request test1, only to get mailman complaining
      about the gid
   7. by-passing root/sendmail as in: sudo -u mail "test" |
      /etc/smrsh/mailman request mailman, only to still get a gid complaint.
   8. restarting Sendmail daemon and Mailman's qrunner daemon after
      config changes.

By the way, i've done extensive reading of:

    * Mailman INSTALL
    * Mailman README.LINUX
    * Sendmails various READMES pertaining to SMRSH etc
    * the mailman-developers list archives

At this point, i'm out of ideas on what to try, except to abandon 
Mailman and switch to something like Majordomo, etc.   And frankly i 
think i've run out of time.  I've spent several evenings on this 
already.  Getting any kind of mailing list up and running is more 
important than the bells and whistles that Mailman offers.


-keith s.

More information about the Mailman-Developers mailing list