[Mailman-Developers] Maybe it's time to release 2.1.6

Dallas Bethune dallas at dreamhost.com
Wed Dec 1 19:39:01 CET 2004

On Dec 1, 2004, at 8:49 AM, John W. Baxter wrote:

> On 12/1/2004 6:05, "Barry Warsaw" <barry at python.org> wrote:
>> I have no problems requiring Python 2.4 for Mailman 2.2, although I
>> would like to get some feedback from the community before we decide 
>> for
>> sure.  I wouldn't be opposed to requiring at least Python 2.3, but I
>> definitely think we should drop support for earlier Pythons since
>> nothing earlier than 2.3 is being maintained any more.
> The Debian part of the community in particular (of which I am not 
> part).  I
> wonder when Python 2.4 will wander into a Debian release.
> Perhaps a query on the -users list about requiring Python 2.4 with 
> Mailman
> 2.2 would produce a solid reason not to.

We use Debian so this would be of some concern.  It looks like the 
newest version of python provided by any version of Debian is 2.3.4 at 
the moment, and the stable version still includes only 2.1.3.

Compiling a python binary is an option, but it would add some extra 
overhead to the upgrade.  If you all think it's the best way to get a 
good stable set of features for Mailman, we're willing to do it, 


More information about the Mailman-Developers mailing list