[Mailman-Developers] Maybe it's time to release 2.1.6

Ian Eiloart iane at sussex.ac.uk
Thu Dec 2 11:47:25 CET 2004

--On Wednesday, December 1, 2004 09:05:20 GMT -0500 Barry Warsaw 
<barry at python.org> wrote:

> On Tue, 2004-11-30 at 20:07, Tokio Kikuchi wrote:
>> Sorry my response is slow :-)
> No worries!
>> Yeah, I think I can contribute 2.2 while you are at 3.0. Looking back
>> the design notes, we have already some of 2.2 features in 2.1.6.
>> http://zope.org/Members/bwarsaw/MailmanDesignNotes/MailmanTwoDotTwo
>> May be we can go forward to requirement of Python 2.4 because CJK codecs
>> are integreted there.
> I have no problems requiring Python 2.4 for Mailman 2.2, although I
> would like to get some feedback from the community before we decide for
> sure.  I wouldn't be opposed to requiring at least Python 2.3, but I
> definitely think we should drop support for earlier Pythons since
> nothing earlier than 2.3 is being maintained any more.
> -Barry

Here's some feedback:

We're running python 2.2.3 on Solaris, but we only use python for Mailman, 
so a forced upgrade wouldn't be too painful.

However, MacOSX and MacOSX Server have python Python 2.3 (#1, Sep 13 2003, 
00:49:11), so requiring 2.4 could cause pain for anyone with a Mac 
installation of Mailman.

Now, I know someone is going to point out that Apple provide a much hacked 
version of Mailman - but that's a red herring. I'm referring to people who 
put vanilla mailman on top of MacOSX - as we plan to do. We're migrating 
our mail servers to MacOSX, but we're using Exim, not the Apple provided 

Ian Eiloart
Servers Team
Sussex University ITS

More information about the Mailman-Developers mailing list