[Mailman-Developers] Mailman 2.X CVS MAIN is back

Ian Eiloart iane at sussex.ac.uk
Thu Sep 1 15:18:14 CEST 2005

--On 1 September 2005 10:03:31 +0200 Tollef Fog Heen <tfheen at err.no> wrote:

> * Barry Warsaw
>| At the very least, we must drop Python 2.1 and 2.2.  Neither of those
>| versions are being supported any longer and I will definitely not claim
>| to have tested the current code base on either version in a very long
>| time.  If we must continue to support Python 2.3, so be it, but I'd like
>| to leapfrog even that version.  There are several Python 2.4 constructs
>| and modules that I'd dearly love to be able to take advantage of.
> The default python version in Debian is still 2.3, so I would really
> like 2.3 to be supported for MM2.2.

So, here <http://packages.debian.org/stable/python/> we see that the 
version of Python in Debian stable ('sarge') is python (2.3.5-2), as it is 
in Debian testing ('etch') release, and in Debian unstable ('sid')!

Mailman releases are mailman (2.1.5-8) through (

I reckon that Mailman 2.2 isn't likely to get into any of these releases, 
whether it requires 2.3 or 2.4.

My view is that Debian should not be allowed to hold up anyone's 
development cycles. As far as I know, it still ships with exim 3 as the 
default mailer, over three years after exim 4 was released. I think that 
even 'sid' ships with exim 3 as the default mailer.

Ian Eiloart
Servers Team
Sussex University ITS

More information about the Mailman-Developers mailing list