[Mailman-i18n] slovene .po file corrupted

Matjaž Kljun matjaz.kljun at pef.upr.si
Mon Jan 19 05:10:31 EST 2004

Looks like I've seached every corner of the web to solve this 
problem. And found olny one person having the one like me. But
the sollution unfortunately doesn't work .-(


I'm running the Mailman 2.1.4 and whne I try to select Slovene 
as a default language Mailman hits this error.

Traceback (most recent call last):
  File "/usr/local/mailman/scripts/driver", line 80, in run_main
    pkg = __import__('Mailman.Cgi', globals(), locals(), [scriptname])
  File "/usr/local/mailman/Mailman/Cgi/listinfo.py", line 35, in ?
  File "/usr/local/mailman/Mailman/i18n.py", line 35, in set_language
  File "/usr/local/lib/python2.2/gettext.py", line 248, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/local/lib/python2.2/gettext.py", line 106, in __init__
  File "/usr/local/lib/python2.2/gettext.py", line 180, in _parse
    k, v = item.split(':', 1)
ValueError: unpack list of wrong size

I went to download the last mailman.po file and compiled it (msgfmt 
-o mailman.mo mailman.po) and overwrited the old file but it does't 
help. I reported this bug at SF.org but haven't got any answer yet
(my impatience).

All other languages are working fine!

Any Idea how to solve this problem? 

Thank you

Poslano iz: https://www.pef.upr.si/Portal/horde/imp

More information about the Mailman-i18n mailing list