[Mailman-Users] Hi and, well, er, Help!

Mark mark at warren-wilson.edu
Fri Aug 7 05:13:51 CEST 1998

Hi there.  First, I must say that I am a Social Sciences major who has a
work study job in the computer dept at my college, so please excuse that I
am not that bright with computers and thus this silly question.

We are transferring the administration of our all-campus mailing list to
the Director of Propaganda..er Public Information and mailman looked like
real sexy way for him to be able to administer and, well, I didn't want to
setup majordomo again cause I was in hospital for weeks after an attempt
on my own life due to sheer frustration.

Anyway, here is the lowdown:

the system is a Pent 200 running Debian 2.0
	apache          1.3.0-2 
	python		1.5.1-4

The compile seemed to go well, the web pages it made worked ok and looked
real nifty.  I did manage to generate the error: 

	Mailman mail-wrapper:
	Failure to exec script. WANTED gid 8, GOT gid 1002.  (Reconfigure to take

But I fixed that with a recompile.  When the test list was created, it
sent me a message just as it should have.  An attempt to subscribe via the
web page sent a message just as it should have.  But....  both an attempt
to send for the "help" message and to reply to the subscribe message
produced this message to mail-daemon:

	"/home/mailman/mail/wrapper mailcmd test" ... failed: transport file:
	failed to open output file: Permission denied

and the smail logs produce this...

	08/06/1998 21:42:36: [m0z4bYC-000XZdC] Delivered TO:
	ORIG-TO:<test-request at robin.warren-wilson.edu> DIRECTOR:aliases
	08/06/1998 21:42:36: [m0z4bYC-000XZhC] Received FROM:<+>
	HOST:robin.warren-wilson.edu PROTOCOL:bsmtp PROGRAM:smail SIZE:1384
	08/06/1998 21:42:36: [m0z4bYC-000XZhC] Delivered VIA:owl.warren-wilson.edu
	TO:mark at warren-wilson.edu ORIG-TO:<postmaster> ROUTER:inet_hosts
	08/06/1998 21:42:36: [m0z4bYC-000XZhC] Completed.
	08/06/1998 21:42:38: [m0z4bYC-000XZdC] Error sent
	FOR:"/home/mailman/mail/wrapper mailcmd test" TO:postmaster
	08/06/1998 21:42:38: [m0z4bYC-000XZdC] Completed.

Stuff seems to have the right permissions, I tried every combo, changing
the group to mail, putting both mail and mailman in each others groups and
then finally putting hte whole /home/mailman into super slut mode 777.
Still no go... 

Any suggestions out there?  (and remember, I am a social sciences major,
so use small words).


More information about the Mailman-Users mailing list