[Mailman-Users] Sun recommended patches breaks python/mailman, help!

Farul Ghazali farul at cuccfa.ccc.columbia.edu
Tue Oct 27 17:54:00 CET 1998

I posted this on comp.lang.python, but thought I should post here too. I
recently installed the Sun Recommended patches on my Solaris 2.5.1 x86
box, along with the Sun Year 2000 fixes for it. Unfortunately, this broke
my mailing list server and I didn't realize it until about 2 weeks later
(very quiet mailing list :) 

At first it seemed as if all the mail was bouncing back, so I backed out
of the sendmail patch from Sun's huge patch cluster. Then mail was getting
out, but nothing else worked. 

I'm running Python 1.5, with mailman 1.0b4 over Apache 1.3.0. The second
thing I tried doing was upgrading everything (apache 1.3.3, Python 1.5.1
and mailman 1.0b5), which was a big mistake, since mailman 1.0b4 and 1.0b5
doesn't seem to work with Python 1.5.1 at all ( something about a CRYPT
error even though I did compile in the crypt module). 

So I reverted back to Python 1.5 with mailman 1.0b4, which so far seems to
work from the command line. However, I'm still having problems with the
web server, accessing the admin page gives the following error

Traceback (innermost last):
  File "/export/home2/mailman/scripts/admin", line 836, in ?
  File "/export/home2/mailman/scripts/admin", line 149, in main
    lst = maillist.MailList(list_name)
  File "/export/home2/mailman/Mailman/maillist.py", line 64, in __init__
  File "/export/home2/mailman/Mailman/maillist.py", line 546, in Load
  File "/export/home2/mailman/Mailman/maillist.py", line 887, in Lock
    self._lock_file = posixfile.open(
  File "/usr/local/lib/python1.5/posixfile.py", line 216, in open
    return _posixfile_().open(name, mode, bufsize)
  File "/usr/local/lib/python1.5/posixfile.py", line 81, in open
    return self.fileopen(__builtin__.open(name, mode, bufsize))
IOError: (13, 'Permission denied')

Exception exceptions.AttributeError: '_file_' in ignored 

Accessing the listinfo page gives an Apache internal server error. 

I'm going to revert back to Apache 1.3.0, and if that doesn't work,
backout of the multiple patches I installed for y2k and security. This
seems somewhat drastic so I'd really appreciate any tips from anyone
before doing this.

Thanks much.

More information about the Mailman-Users mailing list