[Mailman-Users] newbie sgid problems/questions

Skip Montanaro skip at mojam.com
Sun Dec 5 20:10:40 CET 1999

Sorry to bomb the list with a newbie question without being subscribed to
the list or perusing the archives, but www.python.org is unavailable at the
moment and I'm heading out of town for a few days and would like this not to
sit unresolved for a week if possible.  I didn't see my problem addressed in
the FAQ

I installed mailman on my RH 5.2 system with the following configure

   ./configure  --with-cgi-gid=httpd --prefix=/home/dolphin/mailman

Everything went fine until I tried to add a new user to a newly created
list.  The confirmation reply bombed with the following in /var/log/maillog:

    Dec  5 09:56:59 dolphin smrsh: uid 2: attempt to use wrapper mailcmd rma

No problemo.  Just add the appropriate symlink.

Then I got:

    Dec  5 10:17:02 dolphin Mailman mail-wrapper: Failure to exec
      script. WANTED gid 12, GOT gid 2.  (Reconfigure to take 2?)

Group 12 is "mail".  Group 2 is "daemon".  Okay, so I manually changed the
group for mail/wrapper to "mail".  No change.  Realizing there is some
checking code in the wrapper program itself, I tried "make clean" and then
reconfigured with

    ./configure  --with-cgi-gid=1000 --prefix=/home/dolphin/mailman --with-mail-gid=12

(1000 == httpd, 12 == mail)

Upon installation (as user "skip"), the mail/wrapper program was still group
"mailman" (the setgid bit was set however), so as root I manually changed
its group to mail.  I still get the same "Failure to exec" message in

The installation instructions explicitly said to not perform the
build/install step as root:

    You should not be root while performing the steps in this section.
    Do them under your own login, or whatever account you typically
    install software as.

This is typically me (skip).

    However, make sure that you have write permissions to the target
    installation directory, and permission to create a setgid file in
    the file system where it resides (NFS and other mounts can be
    configured to inhibit setgid settings).

It doesn't complain when I install, but still installs the wrapper as group
"mailman".  Do I need to be in the group "mail"?


Skip Montanaro | http://www.mojam.com/
skip at mojam.com | http://www.musi-cal.com/
847-971-7098   | Python: Programming the way Guido indented...

More information about the Mailman-Users mailing list