[Mailman-Users] GID problems (and yes, I ran with --with-mail-gid)

Scott A. McIntyre scott at whoi.edu
Mon Feb 8 15:01:02 CET 1999


I seem to be running into something that must be even more obvious than
running configure --with-mail-gid=X after doing a make clean (or even
removing everything and re-untarring)...

My logs say:

Feb  8 08:49:02 3C:tardis Mailman mail-wrapper: Failure to exec script.
WANTED gid 300, GOT gid 998.  (Reconfigure to take 998?)

When I ran configure, I ran it as so:

./configure --prefix=/usr/people/mailman --with-mail-gid=300

And no errors were reported.  Yet whenever I post to a list (in this
case, test) I get a bounce and a message in the log like above.

998 is the GID of a "guest" group which as far as I can tell, isn't
actually used for anything within mailman or sendmail.

My passwd entry for mailman:

mailman:x:301:300:Mail Man:/usr/people/mailman:/bin/csh

And group:


I've also tried


as a group entry, but of course that didn't have any effect.

I must be missing something stunningly obvious...any assistance would be
gratefully accepted!

Oh, and the wrapper is set:

-rwxr-sr-x   1 root     mailman     19192 Feb  8 08:46 wrapper*



More information about the Mailman-Users mailing list