[Mailman-Users] Mailman & QMail

Christian Tismer tismer at appliedbiometrics.com
Sat Feb 20 20:33:21 CET 1999

Martin Preishuber wrote:
> Hi there,
> I've just installed Mailman 5 times without too great success ...
> I guess the problem is qmail-related ... The installation went fine
> (I used configure --prefix=/home/users/mailman --with-mail-gid=qmail
> --with-cgi-gid=nobody which seems to be correct) but mailman just
> doesn't send any mail ... when I create a new list with newlist,
> it doesn't do anything (at least there's nothing in the maillog)
> plus when subscribing to a mailinglist, the mail gets forwarded
> to list at host but then there's nothing again ... could anyone
> give me some hint, what I'm doing wrong ?

You must enable alias processing for qmail. 
See doc/INSTALL.alias .
Also make sure that /usr/lib/sendmail is soft-linked to
/var/qmail/bin/sendmail .

A last thing which hit me for the crew list on Starship was
the qmail dash handling. I didn't get anything through to
starship-crew, since a user starship existed, and qmail
tried to find a .qmail-crew settings file in the starship home.
You can circumvent this by a couple of extra entries. I did
the most easiest thing: Renamed the list to "crew" and it
worked immediately.

ciao - chris

Christian Tismer             :^)   <mailto:tismer at appliedbiometrics.com>
Applied Biometrics GmbH      :     Have a break! Take a ride on Python's
Kaiserin-Augusta-Allee 101   :    *Starship* http://starship.python.net
10553 Berlin                 :     PGP key -> http://wwwkeys.pgp.net
PGP Fingerprint       E182 71C7 1A9D 66E9 9D15  D3CC D4D7 93E2 1FAE F6DF
     we're tired of banana software - shipped green, ripens at home

More information about the Mailman-Users mailing list