[Mailman-Users] issues with BSD/OS 4.0 and mailman 1.0b8

Vivek Khera khera at kciLink.com
Mon Feb 22 18:21:25 CET 1999

The web site says that Python 1.5 or newer is required.  It seems to
be that 1.5.1 or newer is required, as the "getpass" module does not
exist in 1.5.

Also, under BSD/OS unix (and most BSD in general) the group setgid bit 
is not necessary on directories -- the default bahavior is to use the
directory's group when creating new files.  Having the setgid bit
causes annoying security alerts, but is otherwise harmless.

The INSTALL document says that the default list for --with-mail-gid is 
'other daemon'.  However, the wrapper on my system was build to be
setgid mailman.

I'm building Python 1.5.1 now, so when I get it going, I may report
more... ;-)


Vivek Khera, Ph.D.                Khera Communications, Inc.
Internet: khera at kciLink.com       Rockville, MD       +1-301-545-6996
PGP & MIME spoken here            http://www.kciLink.com/home/khera/

More information about the Mailman-Users mailing list