[Mailman-Users] help setting up mailman

Boris Goldowsky boris at infoplease.com
Fri Mar 19 23:14:27 CET 1999

Roger Peña Escobio diagnosed my problem correctly.  Copying the mail/wrapper
into /usr/adm/sm.bin solved that problem.

However, now I get different errors when I try to subscribe.  I entered my
email address on the web form to subscribe, received the confirmation
message, replied to it, and the answering email I get is included below.

I did try setting  /opt/mailman/scripts/*  to be executable (they were
installed with mode 664), but that didn't help.  Any clues?


The original message was received at Fri, 19 Mar 1999 16:23:47 -0500 (EST)
from banana.infoplease.com []

   ----- The following addresses had permanent fatal errors -----
"|/usr/adm/sm.bin/mailman-wrapper mailcmd mmtest"
    (expanded from: <mmtest-request at infoplease.com>)

   ----- Transcript of session follows -----
Traceback (innermost last):
  File "/opt/mailman/scripts/mailcmd", line 52, in ?
  File "/opt/mailman/Mailman/MailCommandHandler.py", line 162, in
    self._cmd_dispatch[cmd](args, line, mail)
  File "/opt/mailman/Mailman/MailCommandHandler.py", line 512, in
  File "/opt/mailman/Mailman/MailList.py", line 874, in ProcessConfirmation
    got = Pending().confirmed(cookie)
  File "/opt/mailman/Mailman/Pending.py", line 80, in confirmed
    db = self.__load()
  File "/opt/mailman/Mailman/Pending.py", line 94, in __load
  File "/opt/mailman/Mailman/Pending.py", line 120, in __assert_lock
  File "/opt/mailman/Mailman/flock.py", line 119, in lock
    os.link(self.lockfile, self.tmpfname)
os.error: (13, 'Permission denied')
554 "|/usr/adm/sm.bin/mailman-wrapper mailcmd mmtest"... unknown mailer
error 1

-----Original Message-----
From: Roger Peña Escobio [mailto:roger at infomed.sld.cu]
Sent: Friday, March 19, 1999 3:55 PM
To: mailman-u; Boris Goldowsky
Subject: Re: [Mailman-Users] help setting up mailman

-----Original Message-----
From: Boris Goldowsky <boris at infoplease.com>
To: 'mailman-users at python.org' <mailman-users at python.org>
Date: Friday, March 19, 1999 3:33 PM
Subject: [Mailman-Users] help setting up mailman

>I'm trying to set up mailman to run on a Solaris 2.5.1 system with sendmail
>8.9.3.  The configure, build, and creation of a test mailing list worked
>without errors.
>However, when I send any message that tries to use the wrapper function, I
>get the following error in syslog:
>Mar 19 14:43:51 spaceheater sendmail[18681]: OAA18681:
>   to="|/opt/mailman/mail/wrapper mailowner mmtest",
>   delay=00:00:00, xdelay=00:00:00, mailer=prog,
>   stat=Operating system error
make  a link to the mailman wrapper programs in the /etc/smrsh dir
#ln -s /home/mailman/mail/wrapper wrapper
maybe your sendmail need this for run the wrapper programs

>Mailman-Users maillist  -  Mailman-Users at python.org

More information about the Mailman-Users mailing list