[Mailman-Users] smrsh + mailman = "unknown mailer error 2", but not always...

Luca Polo jake at gest.unipd.it
Mon May 24 16:44:45 CEST 1999

Hallo everyone,

this is  my first post on  this forum, and  although I find Mailman  a very
good piece  of software, I already  have a puzzling  question (puzzling for
me, at least...).

I've  just installed  mailman 1.0rc1  under Solaris  7 +  sendmail  8.9.3 +
python 1.5.2, and I've experienced the same behaviour John-David Childs has
described a while  ago (thread "Desperation Time! :)",  which I've found in
the May archive).

Strangely enough, I got this error after the first install, but mailman al-
so reported an error in the mail GID I had chosen, so I reinstalled it from
scratch with the right GID, and it worked fine. For a while.

Today, mail  delivering stopped  working again, with  the same  error. I've
made some tests, and at last I recompiled the wrapper with the GID_MISMATCH
macro in src/common.h redefined to "99"  instead of the default "2" (I cho-
osed "99" randomly, just to see  if "mailer error 2" would have been trans-
formed in "mailer error 99",  or something more interesting :-); BTW, smrsh
*is*  correctly  configured, with  a  symlink  to ~mailman/mail/wrapper  in
/usr/adm/sm.bin, etc.).

I then just copied only  the "wrapper" binary to ~mailman/mail and restored
its permissions to -rwx-r-sr-x, leaving everything else untouched (I double
checked that owner, group and permission were the same before and after the
test; I also saved a backup copy of the old executable).

Well,  I didn't  expect it  to work,  but it  worked, and  this is  quite a
nonsense, since it looked "obvious"  that there was no relationship between
GID_MISMATCH  and the error  code returned  by smrsh  (at least,  not after
having correctly confiugred the mail  GID). I also recompiled smrsh, expli-
citly adding /usr/local/bin  in its internal PATH, just to see  if it was a
problem of  finding python, but  nothing changed...  Looking at  smrsh code
shows nothing  interesting: it just performs  a few "sanity  checks" on the
command string passed by sendmail and if it's all OK, it just spawns a real
shell which in turn executes the wrapper, etc.; and the wrapper is not much
more complex than smrsh...

So,  I just returned  to the  old wrapper  (GID_MISMATCH =  2) and  the old
smrsh, and  everything keeps working  fine, but I'm still  wondering *what*
caused  this strange behaviour...  At a  first glance,  it seems  that just
replacing the  "old" wrapper  with a "new"  (identical!) one, is  enough to
"unblock" something somewhere, but the Big Question is "what and where?".

Any hint?

Best regards,
Luca Polo.
 / Luca Polo : Luca.Polo at gest.unipd.it || Dipartimento di Tecnica e        \
|  System & network administrator      || Gestione dei Sistemi Industriali  |
 \ http://www.gest.unipd.it/~jake      || Universita` di Padova -- Italy   /

More information about the Mailman-Users mailing list