[Mailman-Users] Mail wrapper and GID error

Mark mark at mystic.nu
Wed May 26 05:55:55 CEST 1999

I set up a test mailing list and I Can go to the webpage and fill in
everything and I get the confirmation email just fine. When I reply to
confirm I get the following errors.

Syslog shows May 25 22:34:08 emily Mailman mail-wrapper: Failure to exec
script. WANTED gid 12, GOT gid 2.  (Reconfigure to take 2?)

And the email says:

  ----- The following addresses had permanent fatal errors -----
"|/home/mailman/mail/wrapper mailcmd test"
    (expanded from: <test-request at mystic.nu>)

   ----- Transcript of session follows -----
554 "|/home/mailman/mail/wrapper mailcmd test"... unknown mailer error 2

When I run configure, it automatically picks 12 as the GID for mail but if
I try any other GID including 2 with ./configure --with-mail-gid
it says configure: error: 
***** No existing group found for the mail_wrapper program.

I've tried every GID I have! :) None of them work though. SO I guess what I
need to know is how the heck do I find (or make) the proper group/GID that
sendmail uses?

I'm running Linux 3.6 with kernel 2.2.5 and sendmail-8.9.1 if this makes
any difference. Thanks in advance for any help!

More information about the Mailman-Users mailing list