[Mailman-Users] newbie setup problem (--with-cgi-gid not working)

Miles Fidelman mfidelman at ntcorp.com
Fri Nov 26 19:14:55 CET 1999

Hi Folks,

I'm just trying to get mailman set up, and I seem to have run into a GID

Solaris 2.6 (Sparc)
Python 1.5.1
Mailman 1.1
Apache 1.3.3

1. I ran configure as follows:

./configure --with-cgi-gid='neigh artsadmin nobody'

and they showed up in config.cache ok (I think), as:

ac_cv_group_cgi=${ac_cv_group_cgi='neigh artsadmin nobody'}

then made and installed Mailman.

2. I added a scriptalias to my httpd.conf file as follows

ScriptAlias     /mailman/       /home/mailman/cgi-bin/

3. I created a test list and got email ok (using shell commands).

4. But... when I tried to access the url
http://ntcorp.dn.net/mailman/admin/test (as indicated in the email)
I got the error (in my browser):
Mailman CGI error!!!

The expected gid of the Mailman CGI wrapper did not match the gid as set
by the Web server.

The most likely cause is that Mailman was configured and installed
incorrectly. Please read the INSTALL instructions again, paying close
attention to the --with-cgi-gid configure option. This entry is being
stored in your syslog: 

Failure to exec script. WANTED gid 65540, GOT gid 60001.  (Reconfigure to
take 60001?)

65540 is the gid for the mailman group, whereas 60001 is the gid for
"nobody" the group the server is runnin as, AND one of the GIDs I
originally configured in --- so... what did I do wrong?

Network Technology Corporation	 	    PO Box 600618
Miles R. Fidelman, President 		    Newtonville, MA 02460-0006
mfidelman at ntcorp.com			    617-558-3698
http://www.ntcorp.com		            fax: 617-630-8946			

More information about the Mailman-Users mailing list