[Mailman-Users] help with mailman?

Gregory Leblanc GLeblanc at cu-portland.edu
Mon Apr 3 19:35:11 CEST 2000

> -----Original Message-----
> From: Ron Echeverri [mailto:rone at macromedia.com]
> Sent: Sunday, April 02, 2000 3:45 PM
> To: Gregory Leblanc
> Cc: Mailman-Users list (E-mail)
> Subject: Re: [Mailman-Users] help with mailman?
> Gregory Leblanc wrote:
>   Mar 27 10:58:18 2000 TrySMTPDelivery: To gleblanc at cu-portland.edu:
>   Mar 27 10:58:18 2000 TrySMTPDelivery: socket.error / (110, 
> 'Connection timed out') (deferred)
>   Mar 27 10:58:18 2000 TrySMTPDelivery: Maybe your MTA daemon 
> needs restarting?
>   Sendmail doesn't say that anything is wrong, and I can send 
> mail from
>   ordinary users.  No, my MTA daemon doesn't need restarting, 
> I tried that
>   already.  I've run out of things to look at.
> This happened to me, although my problem was "Connection refused"
> rather than a timeout.  We tuned sendmail.cf by increasing
> MaxDaemonChildren and ConnectionRateThrottle like so:
>     # maximum number of children we allow at one time
>     O MaxDaemonChildren=20
>     # maximum number of new connections per second
>     O ConnectionRateThrottle=10
> I'm guessing that if your connection times out, your server might be
> too loaded.

Thanks that makes a big difference.  :-)  'course I'm still having trouble
and it's covered in A FAQ (why are the troubleshooting docs in three
different locations?).  The problem I'm having now is listed towards the end
of the INSTALL document.  Here's a quote from INSTALL:

    Problem:  I send mail to the list, and get back mail saying,
              "sh: wrapper not available for sendmail programs"

    Solution: Your system uses sendmail restricted shell.  You need to
              configure smrsh by creating a symbolic link from the
              mail wrapper ($prefix/mail/wrapper) to the directory
              identifying executables allowed to run under smrsh.
              Some common names for this directory are
              /var/admin/sm.bin, /usr/admin/sm.bin or /etc/smrsh.
              Note that on Debian linux, the system makes
              /usr/lib/sm.bin, which is wrong, you will need to create
              the directory /usr/admin/sm.bin and add the link there.
              NOTE: any aliases newaliases spits out will need to be
              adjusted to point to the secure link to the wrapper.

So, uhm, since that's not english, I have to guess at what to do.  I've
tried creating a link in /etc/smrsh called wrapper that points to
/opt/mailman/mail/wrapper.  This makes the error when I try to post to the
list go to an account on the mailman machine instead of to the sender of the
message, but it still don't work.  Is that the right procedure?  Do I have
to change something else?  Thanks for any help.

More information about the Mailman-Users mailing list