[Mailman-Users] HELP! Cant get mailman 2.0 to send messages

Scott Brown scott-brown at home.com
Sun Dec 10 04:36:17 CET 2000

I'm having problems incorporating mailman into my server.  the cron jobs ARE
running... (I've uncommented the qrunner startup message to confirm this ;-)

I'm wokring with sendmail 8.8.5 on a RH 5.4 system with Python 1.6 (ya, I
know, none of it is the newest... but it's stable and happy) and I'm getting
messgaes like

Dec  9 22:11:21 apollo sendmail[13440]: WAA13440: <aname at home.com>... relay
attempt failed
Dec  9 22:11:21 apollo sendmail[13440]: Ruleset check_rcpt
(<aname at home.com>) rejection: 550 <aname at home.com>... relay attempt failed
Dec  9 22:11:21 apollo sendmail[13440]: WAA13440:
from=<test-admin at host-ops.com>, size=1647, class=0, pri=0, nrcpts=0,
proto=ESMTP, relay=localhost []

...when any mailman process tries to send email. (note: aname at home.com is
not the true email address... I've replaced it to protect it from spam ..
the addy used does exist and can receive mail from that machine just fine
;-)   Note that I can SU to the mailman user, and sendmail directly from
that, and it works...

I tried installing with the defaults.  No luck.

I tried installing using a mailman:host-opsgrp uid:gid set for mail, and I
got messages saying it WANTED 521, so I changed the last ./configure to

./configure --with-mail-gid=521 --with-cgi-gid=99

did a

make clean
make install

And still I have problems (but the web side of things is working).

The install is apparently clean.

# bin/check_perms
No problems found

The webpages work peachy.

The SMTP wrapper picks up the mail fine, and queues it (I've seen the files
in the /home/mailman/qfiles directory)

But qrunner, and any other routine which tries to send out email keeps

Does anyone have any suggestions as to where to look?

I've had a prof linux admin look at this as well, and he cant figure out
what is causing this to flake out.

More information about the Mailman-Users mailing list