[Mailman-Users] bad marshal data

Dan Mick Dan.Mick at west.sun.com
Wed Jul 12 21:27:19 CEST 2000

Olav at OKvittem.priv.no wrote:
> Hi,
> All mailman scripts started going wrong last night at 05:32:01.
> I run the standard mailman crontab on 2.0b4. I just upgraded from 1.0b9.
> Even running manual scripts like list_lists failed like the one below from
> cron.
> This went on for hours and I got one message from qrunner every minue ..
> I tried a newlist command and then or just before the everything worked again.
> Any explanations/hintsfor what this error-message is due to ?
> regards Olav
>  Traceback (innermost last):
>   File "/home/mailman/cron/qrunner", line 31, in ?
>     from Mailman import Utils
> ValueError: bad marshal data

If that's all it says, no, I have no idea.  "marshal data" surely refers to
the "marshalling" of data, as used in writing the Python object for the mailing
list to disk in config.db...but this statement is nowhere near config.db.

Maybe, somehow, Utils.pyc is a marshalled file, and got corrupted?  Try removing
~mailman/Mailman/Utils.pyc (it'll just be created again as needed) and 
rerun qrunner by hand:

	cd ~mailman
	<python-cmd> cron/qrunner

I didn't know compiled Python programs were marshalled databases, but it would
make some sense, I guess.

More information about the Mailman-Users mailing list