[Mailman-Users] mailman/openbsd/postfix problems

Brian Cohen brian at chimera.acm.jhu.edu
Fri Jun 2 02:39:38 CEST 2000

I'm running Mailman 2.0beta on OpenBSD 2.6. My MTA is postfix. The box
handles virtual domains.

I set up a list, let's call it "foo" and then added the following line to
/etc/postfix/virtual :

foo at domain.com	foo at sandworm.intercarve.net

(obviously domain.com is not my real domain <grin>)
The lines in /etc/aliases are exactly as $prefix/bin/newlist outputs them.
I ran "postalias /etc/aliases" and then "postfix reload".  No matter what,
if I try to send mail to foo at domain.com I get the following message
bounced back at me:

<foo at sandworm.intercarve.net>: Command died with status 2:
    "/usr/local/mailman/mail/wrapper post foo"

I tried following the instructions regarding "smrsh" in INSTALL (I created
the director /usr/adm/sm.bin and symlinked wrapper so that it appeared in
that new directory,but all it changes is the path to "wrapper" in the
error above.

Can anyone shed some light?

Thanks in advance.

-Brian Cohen

More information about the Mailman-Users mailing list