[Mailman-Users] Errors updating lists

Aaron La Mar alamar at partners-intl.net
Mon Jun 5 03:23:32 CEST 2000

I'm trying to upgrade from 1.1 to 2.0beta 2 and am getting the following
errors during the make install process:

Upgrading from version 0xffffffff to 0x20000b2
Updating mailing list:  isep-l
- updating old private mbox file
    looks like you have a really recent CVS installation...
    you're either one brave soul, or you already ran me
- updating old public mbox file
Updating mailing list:  women-east-west
Traceback (innermost last):
  File "bin/update", line 282, in ?
  File "bin/update", line 77, in dolist
    l = MailList.MailList(list)
  File "/usr/local/mailman/Mailman/MailList.py", line 69, in __init__
  File "/usr/local/mailman/Mailman/MailList.py", line 874, in Load
    raise Errors.MMCorruptListDatabaseError, e
Mailman.Errors.MMCorruptListDatabaseError: bad marshal data

Any ideas? My entire mailman system is broken right now. BTW, I'm
using Python 1.5.2. Thanks.

More information about the Mailman-Users mailing list