[Mailman-Users] Possible 2.0beta bug? (was: Unknown mailer error 1 *sigh*)

Derek Simkowiak dereks at kd-dev.com
Thu Jun 15 23:22:48 CEST 2000

[This stems from my earlier error, check the archives if you're feeling

-> Error 126 from sendmail is a permission problem.  Error 2 means it can't
-> open the receiving process, I think.  I believe that error 1 means it
-> can't find the receiver, but not sure.

	(As an aside) Is there someplace to look up these sendmail error

-> In the install instructions, you'll see that the group s bit has to be
-> set.

	That has been done for me by the RPM:

[mailman at platinum mail]$ ls -la /usr/lib/mailman/mail/wrapper
-rwxr-sr-x    1 mailman  mailman     30895 Apr 12 00:45 /usr/lib/mailman/mail/wrapper*

[mailman at platinum mail]$ ls -lad /usr/lib/mailman/mail        
drwxrwsr-x    2 mailman  mailman      1024 Jun 14 15:18 /usr/lib/mailman/mail/

->  I think the kernel enforces the rule about having the directory
-> where the receiver resides be writable only by the owner of the
-> directory.

	By "kernel", you mean the Linux OS kernel?  Interesting, never
heard of that.  I'll try it:

[mailman at platinum mail]$ ls -lad /usr/lib/mailman/mail
drwxr-sr-x    2 mailman  mailman      1024 Jun 14 15:18 /usr/lib/mailman/mail/

	I restarted sendmail (although that shouldn't be necessary), and
still got the exact same error.

	In the bounced confirmation messages, I get this:

>    ----- Transcript of session follows -----
> 553 "|/usr/lib/mailman/mail/wrapper mailcmd... Unbalanced '"'
> Traceback (innermost last):
>   File "/usr/lib/mailman/scripts/mailcmd", line 56, in ?
>     main()
>   File "/usr/lib/mailman/scripts/mailcmd", line 44, in main
>     mlist = MailList.MailList(sys.argv[1])
> IndexError: list index out of range
> 554 "|/usr/lib/mailman/mail/wrapper mailcmd... unknown mailer error 1 

	I think the "IndexError: list index out of range" is the key to
the problem.  What could be causing that?  Could it actually be a bug in
the 2.0beta?

	And where is that " Unbalanced '"' " coming from?  Is that because
the script is dying?

Derek Simkowiak
dereks at kd-dev.com

More information about the Mailman-Users mailing list