[Mailman-Users] RPM installation error

Derek Simkowiak dereks at kd-dev.com
Tue Jun 20 03:59:54 CEST 2000

-> > 	I'm fairly certain the crux of the problem is that I have no file
-> > called "pipermail" on my hard drive.

-> There's no file called "pipermail" on my hard drive either.

	Okay; at least now I'm not operating under the assumption I'm
missing a file.

	Since this does appear (still) to be a problem with the RPM
installation, I'll take notes as I try to fix it:

[ Trying URL:   http://platinum.walldata.com/pipermail/w2hlegacy/
...and wind up with 404 not found.  The URL is what appears on the list's
info webpage as the "archive". ]

[root at platinum cgi-bin]# tail /var/log/httpd/error_log
[...extraneous deleted...]
[Mon Jun 19 18:25:01 2000] [error] [client] File does not
exist: /usr/lib/mailman/archives/public/w2hlegacy/

[root at platinum cgi-bin]# ls -la /usr/lib/mailman/archives/public/w2hlegacy
lrwxrwxrwx    1 mailman  mailman        43 Jun 14 15:24 /usr/lib/mailman/archives/public/w2hlegacy ->

[ It does exist, but only as a symlink. So: ]

[root at platinum cgi-bin]# ls -la /usr/lib/mailman/archives/private/w2hlegacy
ls: /usr/lib/mailman/archives/private/w2hlegacy: No such file or directory

[root at platinum private]# ls -la /usr/lib/mailman/archives/private/             
total 3
drwxrws--x    3 mailman  mailman      1024 Jun 14 15:24 ./
drwxrwsr-x    4 mailman  mailman      1024 Jun 14 15:18 ../
drwxrwsr-x    2 mailman  mailman      1024 Jun 14 15:24 w2hlegacy.mbox/

[ Okay, so I have a w2hlegacy.mbox, but no w2hlegacy.  Hmm... ]

[root at platinum w2hlegacy.mbox]# ls -la /usr/lib/mailman/archives/private/w2hlegacy.mbox
total 2
drwxrwsr-x    2 mailman  mailman      1024 Jun 14 15:24 ./
drwxrws--x    3 mailman  mailman      1024 Jun 14 15:24 ../

[ And the .mbox directory is empty.  Seeing as where I've sent one message
to the list already, which was subsequently sent out to the list, I'd
expect to see some kind of file here. ]

[ ...RTFM to see what it says about archiving: nothing new.  Damn.  The
FAQ does say this:

<faq content>
6. Why doesn't the archive link work?
      Have any messages been posted to the list?  This is a known
      buglet; the archive link doesn't work until at least one message
      has been posted.
</faq content>

	One message has gone through--I'll try another one just to be
sure.  I send another message to the list, watching /var/log/maillog to
make sure things are working: ]

[root at platinum /root]# tail -f /var/log/maillog
[...extraneous deleted...]

Jun 19 18:46:23 platinum sendmail[25989]: SAA25989:
from=<Derek.Simkowiak at netmanage.com>, size=754, class=0, pri=30754,
msgid=<4A5EE1379A0FD211ABAC00A0246ACEB101BB0A0F at exchkirk02.walldata.com>,
proto=ESMTP, relay=exchkirk04.walldata.com []
Jun 19 18:46:26 platinum sendmail[25995]: SAA25995:
from=<w2hlegacy-admin at platinum>, size=1318, class=-60, pri=139318,
msgid=<4A5EE1379A0FD211ABAC00A0246ACEB101BB0A0F at exchkirk02.walldata.com>,
proto=ESMTP, relay=IDENT:mail at localhost []
Jun 19 18:46:26 platinum sendmail[25990]: SAA25989:
to="|/usr/lib/mailman/mail/wrapper post w2hlegacy", delay=00:00:06,
xdelay=00:00:03, mailer=prog, stat=Sent
Jun 19 18:46:57 platinum sendmail[25997]: SAA25995:
to=<Derek.Simkowiak at netmanage.com>, delay=00:00:33, xdelay=00:00:31,
mailer=esmtp, relay=nmmail.netmanage.com. [], stat=Sent
(SAA15337 Message accepted for delivery)

[ Everything appears to have worked normally.  I'm the only person on this
list, and I got the message successfully.  But there is still no file or
directory called /usr/lib/mailman/archives/private/w2hlegacy, and the
.mbox version of that is still empty. ]

	The only thing about my archiving setup is that (1) the archive is
volumed quarterly, and (2) the option that reads:

Set date in archive to when the mail is claimed to have been sent, or to
the time we resend it?

	...is sent to "When resent".  I've seen some archives on the Gnome
lists which are dated the year 2042 (or some such thing), so I moved this
option to "When resent" to avoid that ugliness.

	On a hunch, I put that back to say "When sent", and Voila!  It

	Conclusion:  The archiving "When resent" system is broken in the
2.0beta.  Please fix :)


More information about the Mailman-Users mailing list